Def+ doesn't monitor Comodo dragon [NBZ]

he bug/issue

  1. What you did: downloaded Comodo dragon; created a rule in Def+ for dragon.exe with everytjing on ask; then launched dragon
  2. What actually happened or you actually saw: dragon runs without a flawn but def+ gave no alert, didn’t monitor Dragon. NB : if rules set on block, then Def+ blocked Dragon, but on ask it didn’t react
  3. What you expected to happen or see: pop ups from Def+ telling that Dragon was trying to run, open or use something and asking me what to do allow, block, etc…
  4. How you tried to fix it & what happened:
    changed c:\Program Files\Comodo* to c:\Program Files\Comodo\Comodo Internet Security in the group Comodo Files\Folders in the Protected Files and Folders. No result
    dragged Dragon.exe above All Aplications in Def+ rules. No result
  5. If its an application compatibility problem have you tried the application fixes here?: not relevant
  6. Details & exact version of any application (execpt CIS) involved with download link: Comodo dragon 8, downloaded from Comodo.com
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: not relevant
  8. Any other information (eg your guess regarding the cause, with reasons): I thought first CIS didn’t alert because Dragon is a Comodo product and as such considered safe and trusted by CIS which of course is a problem because Dragon is a brownser and shouldn’t be allowed elevated privileges. But as Def+ blocked the moves of Dragon when the rules are set on block it tends to invalidate my supposition.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: not relevant
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: not relevant
  3. A CIS config report or file. not relevant
  4. Crash or freeze dump file: not relevant

Your set-up

  1. CIS version, AV database version & configuration used: Comodo firewall 5.0163652.1142 proactive configuration; now updated to 5.3.175888.1227 proactive config (problem remains)
  2. a) Have you updated (without uninstall) from CIS 3 or 4: clean install of CIS 5
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): no
  5. Defense+, Sandbox, Firewall & AV security levels: D+=paranoid , Sandbox=enabled , Firewall =custom policy mode , AV =
  6. OS version, service pack, number of bits, UAC setting, & account type: windows xp3 32bits; admin.
  7. Other security and utility software installed: antivir AV
  8. Virtual machine used (Please do NOT use Virtual box): none

account type: windows xp3 32bits

Could you please add the missing information Admin or Limited account to your bug report.

Also could you please confirm that the problem still exist in CIS V5.3

Thank you

Dennis

Hi Dennis

Modifications done in the text above as you asked

Boris

Thank you for your bug report in the required format.

Moved to verified.

Thank you

Dennis