Debug problem when CPF is active[Resolved]

I’ve a problem with debugging programs with OllyDbg when CPF is active. OllyDbg starts opening the program but that’s all: tracing isn’t possible because the OllyDbg doesn’t react anymore. The only way is to close all CPF processes (after removing my internet cable from router) before starting OllyDbg. Is there any way to debug programs with CPF active?

Btw, I’m using latest beta (v2.3.2.21).

CPF will not allow a debugger to debug itself. But it will not block debugger to debug other processes. SoftICE, Windbg, etc. all work correctly. We have not tried OllyDbg but it should work unless it tries to modify CPF processes. What do your CPF logs say about this?

There’s nothing about it in the log file. And btw i tried it on another pc with version 2.2.0.11 and everything works fine. But after installing v2.3.2.21 beta I got the same prob with OllyDbg. So please have a look at this program (Download)…

Just a suggestion, try installing the beta version on the other PC (the one it works on) and test again. If it still works on this PC,the issue is machine specific, not application specific.

Not an answer, I realise, but it would help to narrow the search down.

HTH
Ewen :slight_smile:

I did it already and I thought I told it above but maybe I wasn’t clear enough.

Btw it worked on both PC’s when using CPF v2.2.0.11. The problem is the v2.3.2.21 beta. So I uninstalled it on both PC’s, installed v2.2.0.11 again and everything works fine. So it’s clear to me the problem is with v2.3.2.21 beta. No idea about the other beta’s.

OK, sorry I misunderstood your earlier postings.

Can you please notify Comodo official support by sending an detailed email to support [at] comodo.com.

Thanks in advance,
Ewen :slight_smile:

done

I read about an upcoming new beta release, but I didn’t see any reaction on the debug problem with the current beta version. Do you think this will be fixed in the new beta already?

Next beta is due out Tuesday of next week - but please bear in mind that developer time is horribly elastic!

We’re not privy to what has or hasn’'t been done to the beta until its released. We’ve got to let Comodo have some fun!

Check the forums out next Tuesday - egemen usually posts a comprehensive topic covering the enhancements and bug fixes in the latest beta.

Hope this helps,
Ewen :slight_smile:

The upcoming beta should fix this issue. Because we have fixed a bug which causes similar issues.

Egemen

EDIT: I have just verified that this bug has also been fixed.

Tested with new beta (v2.3.3.33 beta): problem resolved! (:CLP)