DC++ and Comodo?

How to make it work, without security being compromised, e.g. ONLY DC++ is allowed to connect, not any file. If that’s the only option ZoneAlarm from 4 years back does a better job than Comodo (Allow DC.exe, done).

This is what the log spits out right now:

Date/Time :2006-10-31 01:17:57Severity :MediumReporter :Network MonitorDescription: Inbound Policy Violation (Access Denied, Protocol = IGMP)Protocol:IGMP IncomingSource: Destination: Reason: Network Control Rule ID = 6


Please try the steps below.

  1. Open the Comodo Personal Firewall User Interface
  2. Click Application Monitor
  3. Scroll down and highlight the needed application
  4. Right click and click Edit, or just keep it highlighted and press the edit button toward the top right.
  5. Click the “Allow All Activities for this Application” option
  6. Then click the “Allow invisible Connection Attempts” and “Skip Advanced Security Checks” options so they are checked.
  7. Press OK

Please see if this resolves your issue.

No, that gets “(Access Denied, ICMP = HOST UNREACHABLE)”. I told it to Learn the parent BTW.


In that case you may wish to make a specific rule for this application in the network monitor, unfortunately since I do not use the program I cannot tell you how to set this rule. Also when you have created the rule in the Network monitor be sure to move it to the very top so that it will allow the application to pass through without being interfered with by the other Network Monitor Rules.

Try using Firewall with manual port forwarding setting in DC++ and manually open these incoming ports via Network Monitor rules.

It’s starting to be PITA creating more and more rules for every app that has listening ports. Why doesn’t CF create rules automatically or ask at least?

I found out it ain’t working with Comodo off either. I did add the specified port to my Zyxel 2602’s Foward list, and the internal firewall is off. My version of DC++ doesn’t have the option you named. Alternatives?

About Comodo, it’s very inconvenient indeed. Just opened a Word attachment in Outlook Web Access. EIGHT popups! It should just accept anything happening between 2 approved applications. What the fuck do I care whether it’s sending special window messages or it has an altered quadlogic terreflop data stream. Give me my document and quit bitchin’!!

If you want your documents without it complaining, then you can expect a virus to take full effect without it complaining too!!

More automation means less security when being used by technically competent people (As the security is no longer in the competent hands of the user)

EDIT: Fixed up my slightly politically incorrect language.

cheers, rotty

If I tell Comodo applications A and B are cool, then does it matter what they’re doing? What’s the point asking me if it keeps warning?

Actually CF allow to create a rule for app A launched by app B.
What CF really lacks is automatic listening port rule creation for known and trusted apps.

And that should be a firewall’s first feature.

Have you made a network rule for the listening port in CPF?
You can also make a rule in there for ICMP.


I reread the thread and i can’t see any info that you have created a trusted zone?
You mentioned in one post that you couldn’t connect even if CPF was off??
Is it still like that?


You need to make sure that your settings for dc++ on the network monitor settings are before the block & log permission. Took me a while to work that out

I am having the same problems searching with DC++ also. Have tried the above suggestions to no avail… Can anybody help with DC++ searching? Thanks.

This solved it for me:

  • Setup DC++ to use port 5000.
  • Setup NAT of your modem/router to start port 5000, end port 5000, port translation start port 5000, port translation end port 5000.

Happy to hear if that was any help to you.


I already had port forwarding set up properly since I was running DC++ along with Zone Alarm and it worked fine. I am able to log into DC++ fine but can’t search or get file lists.


Does your log in CFP show anything getting blocked?

I finally figured it out. The problem WAS my port forwarding… I had just set up a new pc and the router was assigning it a new lan ip address which I failed to update in the port forwarding settings. Thanks all for your help… :BNC