D+ Keeps Blocking

Although i’ve trusted all the files. (This includes trusting file, trusting in security policy and trusting in firewall)



Is this application still sandboxed?
Can you review it’s status on Defense+ View active processes list and verify the sandbox level and verdict for this app?

Sandbox level is untrusted.

Also i’ve another issue everytime i startup my PC Comodo keeps sandboxing the SAME processes even though i always click “Don’t Isolate Again” and trust all the files ???

This will happen if the process keeps changing. Since CIS now recognizes files by SHA, any change to a process will cause it to be unrecognized. So if the process has some sort of logging feature or other incremental processes, it will be continually unrecognized.

Unfortunately, unless Comodo wants to add back in path based exclusions for processes like this, your best bet is probably to give the application the Installer or Updater security policy, and CIS should leave the file alone.

Go to Defense+ → Computer Security Policy, click the Add button, and Browse to whatever process is giving you problems. Give it the Installer or Updater policy and see if this helps any.

Nope, doesn’t works.
Still keeps sandboxing them every restart :-[

OK, maybe an execution control exclusion may do it.

Defense+ → Defense+ Settings → Execution Control Settings, then click the Exclusions button. Then click Add and Browse

Really had high hopes on this method but still sandboxes :-\

My settings of D+ is Paranoid with everything checked except the TWO AUTOMATICALLY Trust/Detect.
I’ve tried checking and unchecking the 2 sandboxing options and it’s still the same.

CIS is set at “Proactive” Mode

Can you verify if this app doesn’t live on the Defense+ unrecognized files list?

Is this an app that can be downloaded from somewhere so we can try to replicate the issue?

I’ve uninstalled it since then, but i’ll be more than happy to install it back if this is solved.
If i remember correctly the problem was that it was blocking it automatically without any pop up asking for what to do.

As i said before i checked like a hundred times that every thing in every setting was trusted from firewall to D+ even the unrecognized files.

The program is called “Network Magic”, which is a router software that comes with Linksys routers and can be downloaded here: http://www.purenetworks.com/
The main problem with it is that it was blocking the component that manages the “Shared Folders” through Wi-Fi in my network, leaving me unable to use the “Shared Folders”.