D+ is blocking GameGuard.

I am trying to play Drift City, but it just won’t play. I can get it to run, but once GameGuard analyzes cfp.exe (My theory is that it gave itself some sort of protection to prevent disabling) the game just shuts down with an error saying, “Invalid files detected.” I got some other error saying something like, “Running Failed!!!” in exact quotes. Comodo’s Defense+ reports that it blocked 5 intrusions. I added them to the trusted applications and tried disabling everything. Comodo is blocking C:\GamesCampus\DriftCity\GameGuard\GameMon.des and when I right click ‘Allow’, it tells me it is already allowed. Defense+ is on Clean PC Mode. I got Comodo yesterday, which is when the problem started. I have a tournament tomorrow so it’s kind of high priority. If I don’t make it I’ll get kicked out of my crew. I installed CIS because Koobface got past Windows Firewall and AVG. Please help ;-;
Edit: Just tried game mode. No progress at all.

In the past Comodo had serious compatibility issues with GameGuard. It would work with some versions, it wouldn’t work with others. It has never been a happy marriage

Can you post a screenshot of the D+ logs (they are under Defense + → View Defense + Events)?

Please also try adding C:\GamesCampus\DriftCity\GameGuard\ folder to the Exclusions of Detect shellcode injections (i.e. Buffer overflow protection).

Another thing to try is to give GameMon.des the Installer/Updater policy.

Since you are under time pressure you can disable D+ completely with Deactivate Defense+ permanently (Requires a system restart). When this does not help then the only thing left to do is, because of time stress, is to uninstall CIS.

It turns out that the cause of this is an outdated client instead of the firewall. However, it did block it. I cleared the D+ logs because I didn’t know they’d be important. It already had the installer policy, but I’m redownloading Drift City and if the problem is fixed, I’ll close the thread.