D+ intrusions counter doesn't reset when logs cleared [NBZ]

The bug/issue

  1. What you did: On Summary screen, clicked the numbered link (Defense+ has blocked “3” intrusions so far). This opens the Defense+ Events dialogue box. I clicked on More… and cleared the logs (for the Entire Period).

  2. What actually happened or you actually saw: Once the logs cleared, I closed the main log viewer and hit ‘Refresh’ on the D+ Events box. The events listed now disappear (i.e. no logs to display). However, the main Comodo IS Summary page still shows “Defense+ has blocked “3” (for example) intrusions so far”. This number resets straight away after log clearing on some machines I’ve deployed on but not on others. I may be wrong, but it seems that it could be x86 installs clear OK, but x64 machines don’t.

  3. What you expected to happen or see: The Defense+ intrusions counter should have reset to 0 after the logs were cleared.

  4. How you tried to fix it & what happened: Tried refreshing the logs, clearing them again (even though they’re showing as empty) to no avail. Also did a full clean install and this issue still happens.

  5. If its an application compatibility problem have you tried the application fixes here?: N/A

  6. Details & exact version of any application (execpt CIS) involved with download link: N/A

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Happens every time (fails to clear the counter). Reproduce as above: clear the D+ logs, refresh D+ Events dialogue so the events list disappears, but the main CIS 2011 Summary window doesn’t clear the D+ counter to 0.

  8. Any other information (eg your guess regarding the cause, with reasons):
    I may be wrong as most of my machines are x64 and all show this issue. However I’ve installed CIS2011 for a few friends and some have x86 installs of the same OS (Windows 7), and their D+ counters all seem to reset to 0 instantly after the logs are cleared. Can’t be 100% though, just a guess.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Photo showing emptied logs (empty summary screen), also a screenshot showing the D+ counter still displaying events counter on ‘3’ (not reset).

Your set-up

  1. CIS version, AV database version & configuration used: CIS 2011 Premium v5.3.176757.1236 - AV version 7600 - Proactive Security

  2. a) Have you updated (without uninstall) from CIS 3 or 4: NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:

  3. a) Have you imported a config from a previous version of CIS: NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?:

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): Enabled cloud scanning and rootkit detection for AV.

  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe Mode, Sandbox= Enabled, Firewall = Safe Mode, AV = On Access

  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7, no service pack, x64, UAC off / Never Notify, Administrator account (yes, I know, but this machine isn’t for sensitive work and is imaged to external backups daily).

  7. Other security and utility software installed: MalwareBytes (not real-time)

  8. Virtual machine used (Please do NOT use Virtual box): None.

[attachment deleted by admin]

Thank you for your bug report in the required format.

Moved to verified.

Thank you

Dennis