D+ in VirtualBox causes CIS/ CFP to crash and become unresponsive.

Heya guys!!

Got a lil’ more info on the VirtualBox bug mentioned here:

https://forums.comodo.com/bug_reports/comodo_firewall_pro_3025_x32_crashes_in_virtualbox-t27744.0.html
http://www.virtualbox.org/ticket/2496
http://forums.virtualbox.org/viewtopic.php?t=9529&start=30

The bug is caused by the D+ module. If installed without D+, everything is fine.

Anyone know if there is a solution for this?

You do not give up :D.

I see things haven’t gone far to resolve this VirtualBox issue. I told you that if you disable Defense+ then CIS won’t crash on VirtualBox like three weeks ago.

CIS Final still crashes, but as I said before it is rather VirtualBox bug or desing feature which causes CIS to crash. In a matter of fact I couldn't even complete Online Armor 3 instalation on Virtual Box. Other users of VirtualBox complained about Kaspersky 2009 crash issue. Seriously this must be caused by VirtualBox. [b]Besides, this crash only occurs if you have Defense+ enabled.[/b] I do not have currently VM on VirtualPC 2007 but last time I checked CFP worked without any problems on it.

Believe me if this bug would be on CIS side it would be already fixed and we wouldn’t have a warning message informing us that there are some virtual environment restrictions.

Hello.
The problem is indeed on VirtualBox side - it’s not supporting vectored interrupts

Virtualbox v2 and v1 do have an issue with CIS/CFP. The problem in the screenshot shown I have since CFP v3. Reinstalling CFP v3 did not make any difference so I am not going to try that one out on CIS v3.5.
VirtualBox.exe: Defense+ works fine.
VBoxSVC.exe>-<Defense+.
VBoxSVC.exe is the issue: Defense+ cannot use the rules created for it, Defense+ even creates duplicates (!). Initially alerts for the full path exe are created. Then it creates alerts for the ~ path, with duplicates if necessary.

With the rules I have, basically each time I run VirtualBox using Defense+ I have 3 options:

  1. make the VBoxSVC.exe run as “Trusted”
  2. an annoying bunch of alerts
  3. add “Sun Microsystems, Inc” to the “My Trusted Software Vendors” = not an option for me, blocked items

btw. VirtualBox is the solely program I use Defense+ has this odd ~ intercepting thing with, in CFP v3 I got this for Newsbin Pro v5.42 stable also, yet that vanished in CIS v3.5. Wierd huh.

[attachment deleted by admin]

Can anyone check the status of this bug for the most current VirtualBox version?

http://www.virtualbox.org/ticket/2496#comment:9

Reports that it’s fixed in VirtualBox v2.0.6.

fOrTy_7, can you confirm this?

I’ve just tried VirtualBox 2.0.6 with Guest Tools and CIS 3.5.55810.432 installed on it. And nothing has changed. CIS installed on VirtualBox still crashes just after bootup. From my understanding, VirtualBox development team fixed crash and freeze issue for host OS, but the problem is present in guest OS because VirtualBox doesn’t support vectored interrupts.

Just to clear things up here: you are running comodo on the *host*, right? If so, then then next version will fix this for 32 bits Windows hosts.

[attachment deleted by admin]

Think VirtualBox 2.1 corrected this problem?

(Most likely not, but doesn’t hurt to double check :wink: .)

Sorry for digging this thread up, but I wanted to let you guys know that the latest CIS 3.9 RC2 and the Virtual Box 2.2.2 r46594 work fine with each other. There is no crash issue and CIS passes all CTL tests with Proactive Configuration selected on Virtual Box.

Thanks to both development teams for taking they effort to make these two programs compatible.

[attachment deleted by admin]