CWAF installed but not working

Hi, I have installed CWAF but its not working. For example when I run “updater.pl -v”, I get an error:

Can't locate Comodo/CWAF/Main.pm in @INC [...]
BEGIN failed--compilation aborted at ./updater.pl line 10.

Apparently the PERL Modules are still missing even though I have installed them during the CWAF installation procedure.

Hello.

Please, tell us, what software do you use with our plugin.
I mean cPanel/Plesk/DAdmin or standalone installation.

Standalone installation

There is some trouble with our perl modules.
<Can’t locate Comodo/CWAF/Main.pm in [at]INC […]> should contain the path to them.

I think, you need to copy them from /<path_to_cwaf>/cwaf/modules/CPAN/lib/ to this directory.

Seems install was not clean. Can you please send us/review content of install logs file located in /tmp/cwaf_install.log.XXXX ?
Plugin require certain pre-requisites to be met.
For example following components should be present:
cpan - to manage Perl modules
GCC + make - for making Perl modules
sudo - to perform superuser actions like Apache restart

We’re working on next version of installer which will install requirements automatically.

Thank you Oleg. I have sent you a PM with the logs you have requested.

Regards,

Well, I was able to make it work finally. I manually added the modules missing. Took me ages! Probably the documentation should be updated on that sense.

Anyway, now that CWAF installed successfully, I try to start Apache but I get the following error:

[....] Starting web server: apache2Syntax error on line 475 of /opt/cwaf/rules/cwaf_05.conf:
Error creating rule: Unknown variable: MULTIPART_FILENAME
Action 'start' failed.
The Apache error log may have more information.
 failed!

I went to check the RULE file “cwaf_05.conf” and found out that the rule that has the variable MULTIPART_FILENAME is rule #220240
So, I executed the following command:

./cwaf-cli.pl -ea 220240
./cwaf-cli.pl -el

Then, rule #220240 shows in the excluded rules list. I try to start Apache, but I get the same error.

Could you please assist me? (by the way, apache logs don’t show more info)

Hi

mod_security version is too old. Our rules syntax required at least 2.7.5
Here is set of packages for various operation systems:
http://pkgs.org/search/mod_security?type=name

Thank you Oleg.

The latest version that the default repository that Debian installs, is 2.6.6.

So I will install manually the latest version. Thank you very much!