Custom names for rules do not show up in some places [M228]1[v6]

Similar to: https://forums.comodo.com/bug-reports-cis/renaming-a-portset-breaks-rules-gui-v6-t91049.0.html

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: yes, 100%
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

There are certain places where GUI displays default text format “Allow TCP In/Out From MAC Any to …” (this text is of course correct and suits real rule’s params) instead of the custom description we gave to it.

  • Rulesets
  1. Add a new ruleset (for example “myruleset”).
  2. Add to it any rule with custom name (for example “myrule”) with whatever params.
  3. Rule in ruleset will be displayed with params text format (like “Allow UDP Out From IP…”), not our name.
  • Application rules.
  1. Add new application rule for whatever application.
  2. Use a Custom Ruleset & add new rule with whatever params and give it for example “myrule2” description". OR Copy from previously defined ruleset “myruleset”. OR Use ruleset “myruleset”.
    3a. Our rule in rule editor will be displayed with params text format, not our name. (this point for obvious reasons does not apply while using rulesets)
    3b. Our rule in “Application Rules” when we click (+) will be displayed with our custom name however.

Global rules keep its custom descriptions in list.

  • If not obvious, what U expected to happen: rules should use custom descriptions everywhere if they’re not empty (like in 5.12)
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
  • Always attach - Diagnostics file, Killswitch processes list, dump (if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- CIS version & configuration: 6.0.260739.2674, own config

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: all
  • Have U made any other changes to the default config? (egs here.): sure
  • Have U updated (without uninstall) from a previous version of CIS: no
    [li]if so, have U tried a a clean reinstall - if not please do?: no
    [/li]- Have U imported a config from a previous version of CIS: no
    [li]if so, have U tried a standard config - if not please do: no
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: XP Pro, SP3, 32b, admin
  • Other security/sandbox software a) currently installed b) installed since OS: none
    [/ol]

Files attached inc diagnostics, config, processes - PM for pwd.

[attachment deleted by admin]

Yes I’ve seen this too Wilk, thanks for documenting it.

Mouse

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

2708 - not fixed

Updated in tracker.

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

It’s fixed (in 2813 most likely).

Thanks, tracker updated