Custom Added Global Rules under Network Security Policy do not work [Solved]

I’m trying to add a custom Global Rule to prevent in/out traffic to certain IPv4-addresses/ranges or hostnames.

Windows-7, 64-bit.

My custom added Global Rules under Network Security Policy do take effect after applying them.

Example Rule:
Action: Block
Protocol: ICMP
Direction: In/Out
Description: Block ICMP-Ping to
Source Address: IPv4 Address Range
Destination Address: IPv4 Address Range

click Apply, then OK. then start a CMD.exe window and ping/tracert to It works 100%.

I have also added rules to block TCP/UDP.


Hello GM;

I’ll try to assist you
If you are wanting to completely block these address’s please use “Blocked Zones” (tab) for simple and easy way to block IP Address’s/Hostnames etc …

Note; You must move your rule on the top of list to be applied first (The List of rules are prioritized from top (first) to bottom (last)

As for the situation you presented may
What is your private IP Address?
Reason I’m asking, is because if your Private IP Address is 192.168 then the following rule that you posted would not work; because 192 does not apply to 125 through 125;

Log as a firewall event if this rule is fired (enable)
Action: Block
Protocol: ICMP
Direction: Out
Description: Block ICMP Echo Request
Source Address: Network Zone (Choose Your Network Zone Defined in “Network Zones” tab)
Destination Address: Any
ICMP Details: ICMP Echo Request

Then Try to ping; as a result you cannot ping anyone

May i ask what you are trying to accomplish; see if i can assist you further?

Kind Regards

Thanks, your suggestion worked for blocking ping to a particular IP address, with the settings Direction=Out and SourceAddr=“NetworkZone;My Home LAN”.

I guess this means that the rule is an “AND” and not an “OR” for matching source address & dest address. That works.