CTM Snapshot not fully reinstating

Have been using CTM for some time and have been pleased with it, but an issue has arisen which is causing some concern.

I am using Windows 7 Premium on a Toshiba Laptop,3gb memory 170gb HD,Comodo antivirus intalled.

Snapshots are taken at regular intervals manual and daily scheduled, from time to time when restarting laptop after updates or just switched off, windows (CTM) starts to load normal drivers and icons in to system tray and often locks up or just after Comodo antivirus loads, no other icons load in system tray, and if I try and start individual programs they dont start, even though I am already logged in as administrator I have to select program and tell it manually to start in admin mode.

I then run CTM and select a known good snapshot, again very often it does not install run snapshot properly. I then use chkdsk/f and this now takes a very long time to do, all windows updates are done and appear OK.
After many hours yesterday trying to get CTM to work properly Windows did an update of 14 files, rebooted and hey presto laptop started OK and installed snapshot properly.

I love this software but am concerned that there is some conflict with windows 7, has anyone else had similar problem ? At moment CTM seems OK. Thanks in advance for any help.

Dovelea, I had some issues with some snapshots some days ago (the restore finished but I got a BSOD). Not anymore. Yesterday I was testing software, do a restore of an snapshot and it worked. Sorry if I can’t help further.

No problems here with dual boot XP & Win 7. Hundreds of snapshots taken and restored. I have a license for Eaz-Fix Pro but have been using CTM for about a year now. Last weekend I decided to uninstall CTM and go back with Eaz-Fix. CTM’s uninstall went perfect. A few days prior to the uninstall, I updated the baseline which also went smooth. After the uninstall, I did the usual Chkdsk + Defrag + Win 7 System Image of both partitions. I then proceed to boot into XP and install Eaz-Fix. I then boot into Win 7 to install Eaz-Fix and the installer hung and froze the laptop. I had to kill the power to shut it down. I booted back up into Win 7 and the install worked the second time. Long story short, I wasn’t happy with Eaz-Fix anymore after having used CTM for so long now. I restored my image and went back with CTM. All I can say is that it just works well for me. My only compaint is not being able to use my native OS styled theme in the CTM GUI. I do hope this will change soon