CTM is CRAP, all data gone

CTM is the biggest piece of poo i can imagine… i get a warning saying low room on my HD even tho i had 75gb left then i restart and CTM boots my system to the baseline and i cant open CTM to restore to a recent snapshot… now all my poo is gone and my computer is stuck in a state months old… so i ran the installer again to maybe repair the installaton and the only option was to remove. i remembered that wen u remove CTM it gives u an option of which snapshot to go to wen uninstalled but nope, it didnt do shit this time and simply uninstalled itself…

this thing is complete ■■■■, hopefully there is a way to restore all my stuff.

Did it do automatically? I never saw this… Were you uninstalling or just booting?

What do you mean, the interface does not open?
Console does not work?

If CTM was uninstalled to baseline…

Was it working when you opened the interface? Or were you just uninstalling through Control Panel without the interface? Seems that the first uninstallation remove CTM and the snapshots and now you have no other option than to remove the interface…

Indeed… It’s a difficult thing if the snapshots are gone and CTM uninstalled.
You can try Easeus Data Recovery Wizard Free Edition 5.0.1 or Paragon Backup & Recovery Free Edition 10.2. Install them in other computer and try to burn a rescue CD.

i tried uninstalling from windows, it gave an error and the installer exited out without uninstalling, i rebooted to try again and during boot it started uninstalling itself on its own and went to baseline on its own…

ye, it gave me an error wen opening the interface saying some critical component was gone or something.

yes thats right, the snapshots and everything were gone and only option it gave no was to uninstall the windows program interface which wasnt working anyways.

and ill give those 2 programs a shot.

Sorry, I’m not trying to defend CTM, just trying to understand and, if I could, help.
Which error? Do you remember the message?

This is what makes me worry… automated actions without user interaction? ???

Probably the console is the critical component and it was uninstalled before booting. The normal process continues next logon, within Windows, when files and registry keys are removed. But the snapshots and the console and, in fact, CTM, was gone before, on booting for you.

the error had no text for some reason… it just had the yellow alert sign and an OK button which exited the uninstaller before the un-installation began

firzen771, it’s beyond my knowledge and personal experience.
Hope some of the developers could jump and help here.

Hi firzen771:
We are sorry for the trouble that CTM brought you.
Which version of CTM are you using? CTM should not uninstall your system to baseline if you did not choose it during uninstallation. When CTM reports low space, user should reboot to subos, delete snapshots and perform disk compact or uninstall CTM there.
What error message did you get when uninstaller crashed? Did uninstallation in subos start automatically?

Regards
Haibo

Seems so…

its the most up to date version, i checked for an update before doing all this, and yes i know it shuldnt, but it seemed to do it anyways without my approval… and its a bit too late with the low disk space warning thing since CTM is already gone and my data is already all gone. and as i stated earlier, it just had the yellow alert sign and an OK button, there was no text for some reason and the error exited CTM uninstaller before it uninstalled.

I know this is an old post but I have ran into the same problem on a friends laptop. He uninstalled ctm, said to leave the system as it was currently during the uninstall, but it reverted back to February 2010! He has lost 9 months worth of critical business documents that he needs for his job. Is there anything that can be done at all??

I don’t think so.
Sorry.
Hope the programmers and the company (read it staff) take this as the customer experience.

I don’t know whether this will be helpful to anyone, but I think I had the same problem. The Master Boot Record on my computer (Lenovo Thinkpad T400s, Windows 7 Ultimate) got corrupted (error: “There has been a signature failure”). I restored the MBR and was able to boot but my computer had rolled back to a restore point that was 4 months old – not just software and settings but data. For instance, my Outlook inbox showed messages I had deleted months ago.

I was unable to start CTM. I tried reinstalling but kept getting the message that a reboot was needed firstly.

I finally restored my whole system from a recent image backup (fortunately only a few days old) and found a thread here with instructions for unlocking CTM so I could uninstall it.

I believe I was using the most current version of CTM but can’t tell for sure. I have an idea that the problem may have been caused by a conflict with Lenovo’s Rescue & Recovery tool. I hadn’t been using R&R, but my system had been warning me that I needed to upgrade it so I did. The problems started the next day.

Robert

rlweiner, only one program could take care of MBR at a time.
If it get corrupted, the necessary subsystem for CTM can’t be load and will have data loss.
If Lenovo’s Rescue & Recovery tool requires MBR control, it would be incompatible with CTM.

Rlweiner, in your case INDEED it was caused by Lenovo’s Rescue & Recovery tool. Lenovo’s R&R does register itself in the MBR.

Also your CTM version should be 2.8 as it would revert to Baseline when it’s path in the MBR gets corrupted ! (a bug that’s been fixed in 2.9b)

My brother had a same problem, he rolled back to baseline snapshot and lost more documents.
He trying unistall CTM, when CTM attention him about low free space, and he deleting all snapshots expect baseline snapshot.
When he reboot PC - progress bar is not processed for a few hours, and he was reboot PC.
After reboot, CTM display errors such as “Too many bad sectors”. He press Esc to cancel, but about 24% PC was freezing after message - recover files? It may be a long time.
Windows not starting, i entered to disk with Win PE, and when i tryed open folder “Documents and settings” i’ve got a error - Access denied. With programm NTFS access i opened this folder, but files was be old.
Then i entered in MSDART cmd - bcdboot.exe /fixmbr - and Windows showed me a startup logo and gone to reboot.
I fixed this with standart recovery tools on Windows installation disk.
And now i trying recovery files used before select baseline snapshot.
Sorry for my bad english.

You’ll need a powerful restore files tool.
Using CTM was never a substitute for me of backups and even Macrium full sector backup.
It is always a risk to use a tool that is not being developed anymore ::slight_smile:

… Well it’s the best “piece of poo” I have used for this task in years!

Remember, CTM is designed to protect your Operating System: It’s for rolling-back your system.

CTM is not a backup tool.

Never store your Private Data on the same partition as your Operating System!

If you store your Private Data on the same partition as your Operating System, when you use CTM to roll-back your system to a previous snap-shot, you will - OBVIOUSLY - risk losing your Private Data!

Anyway, CTM allows the user to browse the snapshots and restore back the documents/data.