CTM doesn't work and doesn't uninstall in Win7 x64

When I click on CTM after installing and restarting, I get:

“Critical error: A critical subsystem required for proper functioning of the product is not active.
This usually happens with an incomplete installation. Please re-install the product and try again.”

Now, if I try to uninstall CTM I get this:

“You must restart to complete installation first. Then try again.”

I restarted and tried again, it still said the same.

EDIT: This is a x64 issue. On 32 bit Windows it works OK.
EDIT2: After reading some posts in this forum, it seems to me that CTM’s support for x64 systems is pretty weak and buggy. I hope to get an official response about that. Is this software really designed to run on x64 systems?

I got the same error because I forgot to turn of the AV software. Installed fine on a Win 7 Professional x64 after turning off AV.


Nope, only Win7 x64 on that machine. I’ve made several partitions though.

win7/64 - install failed - uninstall failed - software failed - doh

You summed it up very well. It’s disappointing indeed. The software looks promising but they still have a lot of work to do.

Do you have more than one hard disk? And the Win7 x64 is not installed to the first HD ?

Only one disk, 3 partitions:
1 - System Reserved, created automatically by Windows when I installed Win7 x64. About 100mb.
2- 100GB - Windows partition.
3 - 900GB - My data partition.

There may be a 4th 0-length partition at the end of the 3rd (it showed up when I was installing Windows with the CD) created automatically by my former Windows installation, but I can’t find it when I fire up diskmgmt.msc

I’m willing to test this app on my machine again (I just reformatted my 2nd partition it to get rid of the failed installation of CTM) but you gotta promise I’ll be able to uninstall it if anything goes wrong.