CSC will not run after installing

Was using previous version of CSC. Downloaded and installed new version. After install attempted to start program, but get the standard Windows message “Comodo has encountered a problem and must close”
No other programs running that I am aware of. I do have Diskeeper, which is running in the background.

Tried 3 times with fresh uninstall and install with same problem.


The constant crashes that you encountered on your system are mostly because you had uninstalled the previous version of CSC, but there are some leftover files, in the installation directory, that need to be removed manually. So please uninstall CSC, remove leftover files and then install CSC again.

Thank you.

Thanks for the reply, but I need more assistance. You refer to the “installation directory”. Am not familiar with this so can you tell me exactly what I have to remove and how to proceed. Do I have to do anything with the registry etc.?



We meant the install location of your CSC. For example, if you have Windows on drive C, then you have to go to C:\Program Files\COMODO\COMODO System-Cleaner. Please delete the whole “COMODO System-Cleaner” folder (but only after you uninstall the application properly).

Thank you.

I installed comodo system-cleaner and it cleaned up my registry very well. Then a few hours later went to run the program again and got an error message that said I need to re-install the program. I attempted to re-install the program, which was successful, but from that time forward I am unable to use comodo.

I found another website page where it stated that I could repair comodo. I clicked on the link provided and noticed that it was downloading regdefense, which requires I pay for this program.

Does anyone know how to repair comodo system-cleaner without having to install a separate program?
My name is Ann and my email address is FLOWERGIRL14@ROGERS.COM. Thanks for any help anyone can provide.

:slight_smile: Sincerely, Ann


First of all tell us the version of COMODO System Cleaner that you are using, operating system (and whether it’s 32 or 64 bits) and security software installed. Also any error message screenshots that you could provide us with be very useful.

Thank you.

I had similar problem. Try this. Go and find a folder for Comodo System Cleaner in your c drive, program files. Delete the folder. Reboot your computer; go to Comodo and download the current version of System Cleaner and install. It should work; it worked for me.