CSC Hangs During Updates Installation

The initial update that installs - what I presume are - various CSC components, hangs at the end when updating ‘registry filter entries’. Re-installation didn’t help. This time I kept the update running for an hour, but still it wouldn’t finish.

What is the problem?

I can confirm this on Vista. It does not happen on Win 7.

I tried uninstalling, cleaning out Program Files, Program Files\Common Files\ , user%username%\AppData\Local and user%username%\AppData\Roaming to no effect. Disabling upating on start of the program does not help either…

As a consequence you cannot use Disk Cleaner and Privacy Cleaner.

Anybody a clue?

For me Registry Cleaner’s filter is not working. Immediately after saving ‘filter entries’ settings, CSC crashes.

My operating system is Windows XP Professional SP3.

Confirmed on XP SP3.

Applications list update get stuck on “Registry Filter Entries” and Disk/Privacy Cleaner is unusable.

Confirmed on XP Pro SP3.

On initial installation, applications list update get stuck on “Registry Filter Entries”.

Uninstalled and reinstalled. Same result.

Ran Registry Cleaner with Filter Entries unchecked. 600+ errors. Rebooted and finalized changes.

Ran Comodo System Cleaner. Installing updates hangs on Registry Stream MRU with zero progress.

same problem here… update hang at registry filters entries… im on win xp sp3.

already uninstall and reinstall csc… didnt work…

Further information:

Ran Disk Cleaner. Rebooted. Attempted to update but could not connect. ALL INTERNET CONNECTIONS LOST! COULD NOT CONNECT WITH FOXFIRE OR IE.

Restored from log files for Disk Cleaner and Registry Cleaner. Removed Comodo System Cleaner. Most probably WILL NOT REINSTALL.

Confirmed again for XP Pro SP3:

Had old version but that “could not connect to server” for updates, so uninstalled that and installed v2. That first got stuck at updating filter entries.
Updated the fresh install manually to v 2.0.111095.7 and now that hangs on installing updates for Winamp.

The first few minutes you can’t perform scans, but after a while (when the update-window bottom right of the screen should have closed I expect?) you can perform the cleaning tasks you want to…

Don’t know if it’s the update-window that’s just getting stuck or if the actual process of updating is failing, but it’s very annoying :-.

[EDIT] Cleaned registry, rebooted, and now it hangs on “Installing updates: Registry Filter Entries” again, and Disk Cleaner and Privacy Cleaner are not available: no locations to select, completely blank. >:(

[EDIT2] Redownloaded System Cleaner through COMODO website: it’s an older version (2.0.110158.6) and chose “repair” from the install menu. Now through updating it completes the update, but with an error “an error occurred during the update process” and then the window closes.
Disk Cleaner and Privacy Cleaner ARE available for use again though, so seems downgrading doensn’t fix the update-errors but at least returns some functionality again… It’s something, at least… :stuck_out_tongue:


Back again!

Today, ran v 2.0.110158.6, updated and voilá: got through it all perfectly ;D.

But now I’m scared to update to the latest version in case the whole thing crashes again. I’ll give it a shot though, and let you know my findings. Fingers crossed :-.

Success at last (for me anywayz)! :BNC
Upgraded to 111095.7, started up and updating was completed in a flash and without a hitch! Thnx guyz! :-TU

Yes, the update does complete now, and so am I able to use the ‘filter entries’ function.

There are two questions I would like to ask regarding the new CSC -

Firstly, why do I have to download the help file separately, instead of getting it along with the program’s installation? Secondly, how does the Registry Cleaner’s filter-search work, and why was it changed from the ‘keyword’ way of searching as was in the earlier versions?

The Filter option in CRC module hasn’t practically changed, it’s actually improved. It offers the user the possibility to customize the filter search by adding filters for certain registry keys instead of all windows registry. So basically, the user has to select and add a ‘registry path’ and for that path you add the ‘registry value’ you are interested in (keyword driven search).

Regarding Help - it will be provided through COMODO website. This way all the information or changes in the user guide will be more easily updated as the users don’t need to wait for the next releases to see the proper specifications of the product.

Thank you for your support.

But then, If I were to search for entries for a particular software, it would be needed that I know all the value-names of the said software; it is very unlikely that I would. I’d rather have CRC search for all the values related to the filtered keyword.

I do notice that the new way is a huge improvement in terms of accuracy, but it is very impractical.

Today I started CSC and now it updated normally until the very end.

@Cassiopeea Ursu. Is there something you did on your end when sending the update? The only thing that changed was a system restore from Wednessday to Monday and I did a clean install of CIS after I got the infamous 99% CPU usage bug.

Portable 2.0.111095.7 and earlier versions (the main Comodo page has a differnet version, as does the link in the CSC help file!) all fail during updates.

The first failure I had was

After 10+ updates. I gave up. I’ve found where to disable the updates which is an interim method but not a proper solution.

That is VERY poor design.

I also noticed it fails to launch from a batch file. The call is ignored.

CSC seemed like a nice cleaner but, as it refuses to run unless it gets updates which it can’t get…