Critical Error - Failed to start the diagnostics (vista)

In the firewall system status I have the message: The network firewall is not functioning correctly. Please run the diagnostics utility to fix the problem.

When I click Run Diagnostics I get an error that says

“Failed to start the diagnostics. Please make sure that cfpconfig exists in C:\Program Files\COMODO\Firewall”

I am using Vista 32 bit home premium. Does anyone know how to fix this problem, and if not are there any other good free firewalls available?

Hi SeaOtters, welcome to the forums.

Have you added (or removed) any HDDs recently? This is known cause of this type of problem.

Does C:\Program Files\COMODO\Firewall\cfpconfg.exe exist? If so, try to run it directly, out-side of CFP.

Also did the message actually say “cfpconfig.exe” rather than “cfpconfg.exe”? And please confirm which version of CFP you have, thanks.

I have the same exact problem. I did everything possible. Tried to run it manually, nothing loads. I even turned the UAC (User account control) on. Restarted and nothing. I have Windows Vista Premium 32 bit… I am running the version:

If what he said was a typo (about the cfpconfig), then I’m getting a different error.

I get the following error:

The network firewall is not functioning correctly. Please run the diagnostics utility to fix the problem.

“Failed to start the diagnostics. Please make sure that cfpconfg exists in C:\Program Files\COMODO\Firewall.”

The odd thing was there was a period at the end of the location of the file (Not the file itself, in the error message), maybe thats the problem?

I went to miscellaneous in the program. Went to Diagnostics, it ran, and it said there were problems. When it tried to fix them, i got the message that it couldn’t be fixed. There wasn’t much i didn’t do. I ran it (the file cfpconfg) as administrator, i even changed user permissions…

Hope this helps in some way… I don’t have any other security programs on my computer. So nothing could really be conflicting with it, at least not from the security software aspect of it…

Everything else seems to be working, keep up the good work, ill watch for a fix…


Check your Windows Defender permissions for COMODO. That is where I found my problem when I had this error.

Can you be a little more specific? I had it turned off, turned it on, couldn’t find any setting that pertains to the comodo firewall.

I’ll try. The first time I installed Comodo, I ignored Defender. After Comodo installed I started playing around with and noticed that it said it wasn’t functioning properly. Running diagnostics from the Misc. screen told me I had errors. I gave permission to fix the errors. It tried to install a driver, but could not. I became frustrated and uninstalled Comodo. Not one to give up when I like a program, I reinstalled. This time when Defender popped up an alert I paid attention. I had to give permission twice. I don’t remember the first one exactly, but the second was for the driver.

I tried poking around Defender just now to see if I can find something more specific to tell you. Unfortunately, I’m not seeing anything.

Just tossing out a thought, but since you are not running Defender, could you be running anything which could interfere with the driver being installed? Maybe another real time spyware/malware protection program? Or maybe your AV program?

any other way to solve this problem?

Found your post looking for answer to same problem. I eventually turned off the firewall and then selected COMODO Firewall Pro from the All Programs Menu and by right clicking and choosing to Run as Administrator was able to run the diagnostics. This is despite being logged on as Administrator. Maybe has something to do with UAC

I also had the same problem, im running on a windows vista home premium. I did as above poster. Right clicked on the comodo firewall shortcut and choosed “run as administrator”, i also did the same thing on the cfpconfig.exe, restarted my computer, permitted comodo when windows defender asked, and the error dissapeared. The firewall seems to work now!