CPU usage too high...

The last version is having high CPU usage from time to time…
Only booting solve the problem.
Do you know how to debug this? How can I check which other application, driver or dll library is ‘conflicting’ with Comodo? :’(

The I/O reads is extremelly high too…

[attachment deleted by admin]

What other applications are installed?

[tr][td]7-Zip 4.43 beta[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Acronis Disk Director Suite[/td][td]10.0.2117[/td][td]www.acronis.com[/td][/tr]
[tr][td]Acronis True Image Home[/td][td]9.0.3677[/td][td]www.acronis.com[/td][/tr]
[tr][td]Ad-Aware SE Personal[/td][td]1.06[/td][td]http://www.lavasoft.com[/td][/tr]
[tr][td]Adobe Flash Player 9 ActiveX[/td][td]9[/td][td]http://www.adobe.com/go/flashplayer_support/[/td][/tr]
[tr][td]Adobe PDF IFilter 6.0[/td][td]6.0[/td][td]http://www.adobe.com/prodindex/acrobat/main.html[/td][/tr]
[tr][td]Adobe Reader 7.0.8 - Português[/td][td]7.0.8[/td][td]http://www.brasil.adobe.com/[/td][/tr]
[tr][td]Adobe Shockwave Player[/td][td][/td][td]http://www.adobe.com[/td][/tr]
[tr][td]Advanced WindowsCare V2 Beta 3.7[/td][td]-[/td][td]http://www.iobit.com[/td][/tr]
[tr][td]Agere Systems PCI Soft Modem[/td][td]-[/td][td]-[/td][/tr]
[tr][td]AI RoboForm[/td][td]-[/td][td]http://www.roboform.com[/td][/tr]
[tr][td]AlfaClock Free version[/td][td]v1.9.0.752[/td][td]http://www.alfaclock.com/[/td][/tr]
[tr][td]a-squared Free 2.0[/td][td]2.0[/td][td]http://www.emsisoft.com[/td][/tr]
[tr][td]a-squared HiJackFree 2.0[/td][td]2.0[/td][td]http://www.emsisoft.com[/td][/tr]
[tr][td]ATnotes Version 9.5[/td][td]9.5[/td][td]http://atnotes.fr.st[/td][/tr]
[tr][td]AutoIt v3.1.1[/td][td]-[/td][td]-[/td][/tr]
[tr][td]AutoIt v3.1.1.133 (beta)[/td][td]-[/td][td]-[/td][/tr]
[tr][td]avast! Antivirus[/td][td]4.7[/td][td]http://www.avast.com[/td][/tr]
[tr][td]avast! BART CD Manager[/td][td]2.0[/td][td]http://www.avast.com[/td][/tr]
[tr][td]AVG Anti-Rootkit Beta[/td][td]-[/td][td]http://www.grisoft.com[/td][/tr]
[tr][td]Belarc Advisor 7.2[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Blue Coat® K9 Web Protection[/td][td]3.0.34[/td][td]http://www.bluecoat.com[/td][/tr]
[tr][td]BrOffice.org 2.0[/td][td]2.0.9044[/td][td]http://www.openoffice.org[/td][/tr]
[tr][td]CCleaner (remove only)[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Change Case v3.1[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Citeknet CAB IFilter[/td][td]1.5.3[/td][td]http://www.citeknet.com/[/td][/tr]
[tr][td]Citeknet CHM IFilter[/td][td]1.5.3[/td][td]http://www.citeknet.com/[/td][/tr]
[tr][td]Citeknet EXE IFilter[/td][td]1.5.3[/td][td]http://www.citeknet.com/[/td][/tr]
[tr][td]Citeknet HLP IFilter[/td][td]1.5.3[/td][td]http://www.citeknet.com/[/td][/tr]
[tr][td]Citeknet RAR IFilter[/td][td]1.5.3[/td][td]http://www.citeknet.com/[/td][/tr]
[tr][td]Citeknet WDS Mail Add-in (Beta)[/td][td]0.7[/td][td]http://www.citeknet.com/[/td][/tr]
[tr][td]Citeknet ZIP IFilter[/td][td]1.5.3[/td][td]http://www.citeknet.com/[/td][/tr]
[tr][td]ClearProg 1.4.2 Beta 12[/td][td]1.4.2 Beta 12[/td][td]http://www.clearprog.de[/td][/tr]
[tr][td]Comodo Firewall[/td][td][/td][td]-[/td][/tr]
[tr][td]Debugging Tools for Windows[/td][td][/td][td]http://www.microsoft.com/ddk/debugging[/td][/tr]
[tr][td]DriverMax 1.2[/td][td]-[/td][td]http://www.innovative-sol.com/[/td][/tr]
[tr][td]EfreeSoft Boss Key Version 3.30[/td][td]-[/td][td]http://www.efreesoft.com[/td][/tr]
[tr][td]Eraser 5.8[/td][td]Eraser 5.8[/td][td]http://www.heidi.ie[/td][/tr]
[tr][td]ERUNT 1.1j[/td][td]-[/td][td]http://www.larshederer.homepage.t-online.de[/td][/tr]
[tr][td]ewido anti-spyware 4.0[/td][td]-[/td][td]http://www.ewido.net[/td][/tr]
[tr][td]Extensão HighMAT para o Assistente de Gravação de CDs do Microsoft Windows XP[/td][td]1.1.1905.1[/td][td]-[/td][/tr]
[tr][td]Flashpaste Professional 3.93[/td][td]3.93[/td][td]http://softvoile.com/[/td][/tr]
[tr][td]Flock 0.7[/td][td]0.7[/td][td]http://www.flock.com[/td][/tr]
[tr][td]FontFrenzy 1.0[/td][td]1.0[/td][td]http://www.fontfrenzy.org[/td][/tr]
[tr][td]Foreign Language Filter[/td][td]-[/td][td]http://www.hinzen.de/Spamihilator[/td][/tr]
[tr][td]Free Download Manager 2.1[/td][td]-[/td][td]http://www.freedownloadmanager.org/[/td][/tr]
[tr][td]Google Earth[/td][td]4.0.2080[/td][td]http://www.keyhole.com[/td][/tr]
[tr][td]Google Toolbar for Internet Explorer[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Hercule Filter[/td][td]-[/td][td]http://www.hinzen.de/Spamihilator[/td][/tr]
[tr][td]hp LaserJet 1010 Series[/td][td]3.00.0000[/td][td]http://www.hp.com[/td][/tr]
[tr][td]HSLAB Force Down Lite[/td][td]2[/td][td]http://www.hs-lab.com[/td][/tr]
[tr][td]HSLAB Shutdown Folder[/td][td]1[/td][td]http://www.hs-lab.com[/td][/tr]
[tr][td]IE Privacy Keeper[/td][td]-[/td][td]-[/td][/tr]
[tr][td]IFilterShop StarOffice/OpenOffice IFilter WE 1.2 (remove only)[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Intel(R) Extreme Graphics Driver[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Intel(R) PRO Network Connections[/td][td]-[/td][td]http://www.Intel.com[/td][/tr]
[tr][td]Intel(R) PRO Network Connections[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Intel(R) PROSafe for Wired Connections[/td][td]-[/td][td]-[/td][/tr]
[tr][td]IZArc 3.5 beta 3[/td][td]3.5 beta 3[/td][td]http://www.izarc.org[/td][/tr]
[tr][td]J2SE Runtime Environment 5.0 Update 8[/td][td][/td][td]http://java.com[/td][/tr]
[tr][td]jv16 PowerTools 1.3[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Macromedia Flash Player 8[/td][td][/td][td]http://www.macromedia.com[/td][/tr]
[tr][td]Maxthon Browser (remove only)[/td][td]-[/td][td]-[/td][/tr]
[tr][td]McAfee SiteAdvisor for Internet Explorer[/td][td][/td][td]http://www.siteadvisor.com[/td][/tr]
[tr][td]Microsoft .NET Framework 1.1[/td][td]1.1.4322[/td][td]-[/td][/tr]
[tr][td]Microsoft .NET Framework 1.1[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Microsoft .NET Framework 1.1 Brazilian Portuguese Language Pack[/td][td]1.1.4322[/td][td]-[/td][/tr]
[tr][td]Microsoft .NET Framework 1.1 Hotfix (KB886903)[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Microsoft .NET Framework 2.0[/td][td]-[/td][td]http://go.microsoft.com/fwlink/?LinkId=45396[/td][/tr]
[tr][td]Microsoft .NET Framework 2.0 Language Pack - PTB[/td][td]-[/td][td]http://go.microsoft.com/fwlink/?LinkId=45396[/td][/tr]
[tr][td]Microsoft Baseline Security Analyzer 1.2.1[/td][td]1.2.4013.0[/td][td]http://www.microsoft.com[/td][/tr]
[tr][td]Microsoft Office Professional Edição 2003[/td][td]11.0.7969.0[/td][td]http://www.microsoft.com/support[/td][/tr]
[tr][td]Microsoft OpenType Font Properties Extension (Remove Only)[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Microsoft User-Mode Driver Framework Feature Pack 1.0 (Beta2)[/td][td]-[/td][td]http://support.microsoft.com[/td][/tr]
[tr][td]Misspelled Filter[/td][td]-[/td][td]http://www.hinzen.de/Spamihilator[/td][/tr]
[tr][td]Monitor Calibration Wizard 1.0[/td][td]-[/td][td]-[/td][/tr]
[tr][td]MozBackup 1.4.5[/td][td]-[/td][td]http://mozbackup.jasnapaka.com/[/td][/tr]
[tr][td]Mozilla Firefox (2.0b2)[/td][td]2.0b2 (en-US)[/td][td]http://en-US.www.mozilla.com/en-US/[/td][/tr]
[tr][td]MSN Messenger 7.5[/td][td]7.5.0324.0[/td][td]-[/td][/tr]
[tr][td]NetRun (remove only)[/td][td]Version[/td][td]http://www.czarsoft.com/[/td][/tr]
[tr][td]O&O Defrag 2000 Freeware Edition[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Opera 9.02[/td][td]9.02[/td][td]http://www.opera.com[/td][/tr]
[tr][td]Path Copy 3.0[/td][td]-[/td][td]-[/td][/tr]
[tr][td]PeerGuardian 2.0[/td][td][/td][td]http://peerguardian.sourceforge.net[/td][/tr]
[tr][td]PropertiesPlus (Remove Only)[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Realtek AC’97 Audio[/td][td]5.19[/td][td]-[/td][/tr]
[tr][td]Registrar Lite 2.00[/td][td]-[/td][td]http://www.resplendence.com[/td][/tr]
[tr][td]RegScrubXP 3.25[/td][td]-[/td][td]http://home.carolina.rr.com/lexunfreeware[/td][/tr]
[tr][td]Scientific-Atlanta WebSTAR 2000 series Cable Modem[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Secure Outlook[/td][td]2.0.0[/td][td]http://www.programmedintegration.com[/td][/tr]
[tr][td]SpeeDefrag 4.0[/td][td]-[/td][td]http://www.vcsoftwares.com[/td][/tr]
[tr][td]Spybot - Search & Destroy 1.4[/td][td]1.4[/td][td]-[/td][/tr]
[tr][td]Spyware Terminator[/td][td]-[/td][td]http://www.spywareterminator.com[/td][/tr]
[tr][td]SpywareBlaster v3.5.1[/td][td]3.5.1[/td][td]http://www.javacoolsoftware.com/[/td][/tr]
[tr][td]Startup Delayer v2.2 (build 85)[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Super Fast Shutdown 1.0[/td][td]1.0[/td][td]http://www.xp-smoker.com/[/td][/tr]
[tr][td]SUPERAntiSpyware Free Edition[/td][td][/td][td]http://www.superantispyware.com/support.html[/td][/tr]
[tr][td]Time Synchronizer v2.0[/td][td]2.0 (Build:10.06.2002)[/td][td]http://www.softnik.com/[/td][/tr]
[tr][td]TuneUp Utilities 2006[/td][td]5.0.2331[/td][td]www.tune-up.com[/td][/tr]
[tr][td]Uninstall Tool[/td][td]1.6.6[/td][td]http://www.crystalidea.com[/td][/tr]
[tr][td]Unlocker 1.8.5[/td][td]1.8.5[/td][td]http://ccollomb.free.fr/unlocker/[/td][/tr]
[tr][td]USB File Transfer 1.13A[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Virtual Desktop Manager Powertoy for Windows XP[/td][td]1.00.0001[/td][td]http://www.microsoft.com/windowsxp[/td][/tr]
[tr][td]VMware Server[/td][td][/td][td]http://www.vmware.com[/td][/tr]
[tr][td]VMware Server Standalone[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Webshots Desktop[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Wildcard Select 1.1[/td][td]1.1[/td][td]http://www.allyoursoftware.com/[/td][/tr]
[tr][td]Windows Defender[/td][td]1.1.1347.6[/td][td]http://go.microsoft.com/fwlink/?LinkId=55273[/td][/tr]
[tr][td]Windows Defender Signatures[/td][td][/td][td]-[/td][/tr]
[tr][td]Windows Desktop Search [/td][td]02.06.5000.5401[/td][td]http://support.microsoft.com[/td][/tr]
[tr][td]Windows Installer 3.1 (KB893803)[/td][td]3.1[/td][td]http://go.microsoft.com/fwlink/?LinkId=42467[/td][/tr]
[tr][td]Windows Media Connect[/td][td]-[/td][td]http://support.microsoft.com[/td][/tr]
[tr][td]Windows Media Format 11 runtime[/td][td]-[/td][td]http:[/td][/tr]
[tr][td]Windows Media Format 11 runtime[/td][td]-[/td][td]http://go.microsoft.com/fwlink/?LinkId=62768[/td][/tr]
[tr][td]Windows Media Player 11[/td][td]-[/td][td]http:[/td][/tr]
[tr][td]Windows Media Player 11[/td][td]-[/td][td]-[/td][/tr]
[tr][td]Windows Support Tools[/td][td]5.1.2600.2180[/td][td]-[/td][/tr]
[tr][td]WinSnap[/td][td]1.1.7[/td][td]mailto:alexander [ at ] ntwind.com?subject=WinSnap_1.1.7&body=Hi![/td][/tr]
[tr][td]Xteq-dotec X-Setup Pro 6.6.300.Final1[/td][td]6.6.300.Final1[/td][td]http://www.x-setup.net/[/td][/tr]

It that hog Avast! antivirus, Tech! Uninstall it! Tee hee!!! (:WAV)

Agreed, go with something that’s really lite on resources, like oh, I don’t know, Norton maybe?? ;D ;D ;D

avast is not a hog, for sure. I’ve tested it since four years.
Norton Antivirus, on contrary, is notorious a hog.
But, fellows, the problem is that CPF is taking the CPU and not avast.
If there is a problem, I need to solve it. For sure, I won’t uninstall avast.
Comodo will lose the battle…

Easy, mate.
They’re just trying to cheer you up :wink:

Anyway, Have you tried to raise this issue from the following link: https://forums.comodo.com/index.php/topic,2314.0.html ?

Now Tech, we have known each other for years on the Avast forums and there is no telling how many processes you have going on your machine on any given moment. You like to run your machine to its limits. (:KWL)

You should be able to identify which application is causing the firewall to work so hard using the Windows Task Master and look and see which processes are using up CPU resources. Surely there is another process using up too much resources at the same time as the firewall.

I’ll save a list when the problem occurs again.

I wish there are no limits ;D

In fact… not.
Seems a low level conflict. I can simulate the problem unconnecting the cable modem for some time. After half an hour, the hourglasses appear :’(
There is not other process consuming the CPU. If I kill cmdagent.exe, everything becomes normal, except CPF of course.

By the way, is there any possibility of restarting the firewall service?
None stop, start, restart are available in Services console ::slight_smile:

Thanks Culpeper.
Wisanggeni, I’m not upset. I won’t give up on CPF that easy too :wink:

As I’ve already posted, cmdagent also goes ‘bonkers’ on me every now and then.

It starts out as totally unexpected disk activity which basically leaves my system almost inoperable until it stops. During this disk activity I am able to fire up Task Manager and I watch cmdagent go from no CPU utilization up to the mid 50’s. At that point the disk activity stops and CPU utilization for cmdagent gradually drops to zero. Everything is now back to normal.

I get this at random times. Yesterday when I started Norton Ghost 9.0 this happened. I’ve had it happen when I was just sitting at the desktop, doing nothing.

CPF is the new kid on the block not my applications. IMO it is CPF that is at fault and not my applications that I have used without this sort of problem for a long time. This is to be expected with a new program. I just hope the developers dig a little deeper into this to find out why CPF becomes a CPU and disk hog every now and then.

So, I’m not alone :’(

Mine… the same.

I can only achieve this if I kill cmdagent.exe and boot.

I don’t have Norton Ghost in this computer. So, it must have other applications in the same circunstances…

For me, this happens only if I unconnect the cable modem and some minutes after that, not immediatly, not all the times.

It’s a good kid, but it’s a kid for me too ;D

This is happening in two computers of mine with Comodo.
The one without Comodo doesn’t have this problem right now… ??? ::slight_smile:

Just happened again.

Went to a web site, it loaded fine and was just sitting there when all of a sudden disk light comes on. Fired up Task Manager and watched cmdagent start using the CPU. It was in the range of 10-20% while disk activity was present. When the disk light went off CPU utilization gradually increased until it hit a high of 56. Then it quickly fell back to zero.

A computer won’t run without the CPU. The other day I was sitting idle at a street light. The light turned green. My foot did something and suddenly my RPMs went up and i noticed I was moving forward. Defying gravity but not enough to fly. I have another car that does the same thing but not as fast. (:NRD)

Looks like you need something better than Windows Task Master. Something like Task Info:


Also, post the link to the website you described (unless of course…) so I can see if I get the same problem.

Tech, when you disconnect your modem what is the machine programmed to do? Get into the mind of your machine. Make it happen.

I know your analogy must make a point but for the life of me I can’t fathom what it is.

Secondly, it’s not the web site that is the cause. I have this problem randomly doing and not doing different things.

It’s not my job to debug CPF willy nilly. If Comodo wishes to engage my help in my problem, if indeed they even recognize it as a problem, then they can give me instructions. Telling me to uninstall my applications is not acceptable.

Yes I know its free and I do have the choice not to use CPF. But I thought the idea here was to make CPF the best little firewall in the world.

I’ve reported other problems in the past to Comodo that were IMO less then embraced. But guess what? They were problems and they were fixed with a new release of CPF. I suspect this is another one of those problems. I wouldn’t be surprised if the next release does indeed fix my problem.

Ah, I’m not trying to get under anyone’s skin. A blood pressure machine could indicate high blood pressure, which is caused by some other cause. But a blood pressure machine doesn’t cause high blood pressure or create the already present underlying cause. I’m merely suggesting that maybe the firewall is the indicator and not the cause. You want to see a lot of complaints about high CPU usage then you should check out the Firefox or Avast forums. Just a couple of examples. But you seem to only want to report problems you identified with the firewall based on other than scientific methods. Like I went to a website and my firewall CPU usage went through the roof. Please fix the problem with the next release. Since this program is in a beta stage then your use and participation I’m going to assume is that you would like to beta test the program. Simply stating you are experiencing a rare and highly mysterious high CPU usage and pointing your finger at the firewall isn’t much help at all for the folks that create the next release. Maybe my pet peeve of support forums turning into social discussion forums will be fixed with the next release. I’ll be fine after I take my medication. Just bear with me. I’ve had a very hard day at work trying to convince Systems they can figure it out telepathically.

Okay, so I tried to replicate with a simple experiment.

Refreshing this web page causes a single thread under Comodo Service Agent to spike for a second at about 37% and then drops down to about 3% for about 15 seconds then goes to zero. The state of this thread is wait for user request.

Disconnecting the cable modem and watching all threads under the Comodo Service Agent and Comodo Firewall for several minutes results in zero CPU usage.

Sytem idle process is 97% reconciled to TaskInfo (test software), LSA Shell, and Windows Explorer rounding out to 100%.


Excellent analogy - do you mind if I use this in future?

Maybe my pet peeve of support forums turning into social discussion forums will be fixed with the next release.

We are working on this. While Comodo want the forums to be as open as possible, sometimes threads get hijacked, through no bad intentions. The primary focus should be issues and resolutions, but that should not necessarily be the end of it. We all (nearly all) want this forum to be a place that people come back to because of the overall environment - problems, answers, humour, sarcasm, vitriol and all.

Thanks again for the analogy and for taking the time to research streetwolfs issue.

ewen :slight_smile:

I just have a switch that disconnects the cable… I do this when I need fully privacy and security in certain tasks.

For me too… Just that, maybe, maybe, it’s because I go off line. If the off line time is minimum, then no problems later with Comodo.

Fully agree.

Me too. I’ve offered myself to translate it.

Ok. That’s the purpose of this thread. How to debug this?

You’re being ironic or it’s my impression. Culpeper, we can manage avast problems there. avast, for sure, for tests, for experience, is not a resource hog. I like Firefox, although I can’t speak technically about it. Well, about avast I can.

I agree. But, how to debug this?
The firewall is the fever here. Is there a doctor to discover the disease?

;D I’ve tried not using telepathic while posting ‘all’ installed programs in my machine :wink:

Hope Panic isn’t angry with my posts here…

Yeah, I was being facetious. As for my cable modem. I merely shut it off rather than disconnected it. As for the high CPU rates on some machines. I assume it is being caused by intermittent and individual set up of the machine over all, or provoked, which in turn creates a high CPU usage Again, through individual set up of the machine over all. Each of our machines are our own little neighborhoods we created. Tech and StreetWolf may have more convenience stores than mine. ??? That doesn’t mean it is not a problem. A firewall generally doesn’t start working all by itself. It usually just sits there waiting to be fed.

Try turning off Monitor DLL Injections under Application Behaviour Analysis.
Does that do anything?

I’ll try this… but, of couse, it’s a very good feature (not present in some others ‘free’ firewalls) and I don’t want to lose it… Anyway, being offline this will be less problematic.

It’s the same effect…

Ok, but:
a) the digestion should be made by stomach and instestino (the whole computer).
b) the body can’t die by hungry, it must be fed with something (the applications). :wink: