CPIL - leaktest in Vista


I’m new here, and just recently installed Comodo Firewall. And it appears to be good so far!
However, there are few things concerning me…

I ran CPIL, to see how it puts up with it (Vista Ultimate 32-bit & CFP V3 Beta release).
CFP ask a few questions. Since this firewall (and the cpil-test) is new to me, i wasnt really sure what to do… Even after hours of surfing around this forum :().

CPILSuite.exe → cpil.exe
cpil.exe → explorer.exe
cpil.exe → conime.exe

Not really sure what to permit or block, I tried answering in various ways. Also did restarts between them, but nothing happens after typing something in the box and pressing the ‘test1’-button!

Mozilla opens up, and the results are that the message went through. It failed the test.

It says that "can’t start Internet Explorer’. Perhaps this one has something to do with Mozilla being my primary browser?

Where can i check whether i permitted them (i might have accidentally pressed; “remember” the first few times). So that I could remove that rule.
And Vista’s own firewall should be disabled at all time, when using CFP… right…?

Hope i dont appear like an idiot or something :-[ 88) just wanna use this firewall in Vista, since i’ve heard nice things about Comodo.