CPF3 firewalls out client computer on network

I have a small home lan. Host computer runs Xp home with sp2 fully patched. Client computer runs XP
pro with sp2 fully patched. Network architecture is microsoft ICS with connection a crossover cable connecting each computer’s NIC. Internet access accomplished with by dial up 56 K modem on host computer. DNS for host computer is and subnet mask, DNS for client computer is statically set at and sub net The sp2 firewall was and still is disabled on both computers and the net work was named Home Network on both at CPF3 install time. With share net work checked and basic defaults accepted. The same set up worked flawlessly with CPF2.4. All previous HIPS security is now disabled per instructions.

And fails totally on the client computer because the host computer firewalls out all internet access for
the client computer. If I disable the firewall on the host computer, the client computer then gets full internet access also. As soon as I enable CPF3 in any mode on the host computer, the client computer either gets totally firewalled out or sometimes it allows me to open a browser on the client computer but then all bookmarks and even google fail to work and all connection requests time out
on the client computer.

Yes I did read how to post a help request, but thats posting an incredible amount of information.
As an alternate, can I suggest that it might be simpler for someone to post what my network rule set should look like on the host computer. Then I can look to see where it differs from my set up and zero in on the problem faster.

When the new network alert comes up you are suppose to tick the checkbox to allow sharing the connection.

Thank you for a reply-----but what share new network request???

And if I accidentally missed it, how precisely do I get it back at this later time? So I can tell it to share with the host computer?

I have tried numerous clean reinstalls and always get the same result of the host computer firewalling out the client computer on the network. So its possible comodo 3 is remembering a mistake and I can’t recover from that.

But I do really appreciate getting some help. I really do want to get this working and now have many many hours of frustration to show for it.

It is a small green alert that comes soon after cpf is installed. Try deleting the network listed.
If no alert comes than reinstall comodo.