CPF v2 - Email Scanner / AntiVirus

I have been using CPF for some time now and have had few issues except when it comes to my AntiVirus checking my email.
At first I used AVG free and CFP 1.1 and the email checking would turn on and off all by itself. I had all the AV programs added as trusted applications but the problem still persisted. I still could get my email though with no problem and my AV would update with no problem.
I emailed tech support and they suggested I upgrade to CPF 2. I did, and the AV program stopped blinking off, but now I cannot get my email at all. Everytime I try I get the following:
The connection to the server has failed. Account: ‘mail.bhm.bellsouth.net’, Server: ‘mail.bellsouth.net’, Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 10057, Error Number: 0x800CCC0E
I thought It might be a problem with AVG Free so I uninstalled it and reinstalled it, with the same results. I then uninstalled AVG and installed Kaspersky Personal AntiVirus v5.0 to see if this would make any difference. Not only will the email part not scan, but the program will not update itself. I have added all of the programs in the applications as ALLOW all activity (trusted) and have added all their dll files, etc to the components listing and ALLOW.
If I set the Security Level to Allow All, then things work OK. Not a good choice for the firewall though. :cry:
I know I must have just forgot to dot some I to get it to work, but I am at a loss. ??? HELP !!!
My system stats are XP Pro 2GB Ram networked with a Speedstream 5861 4 port Router/DSL modem.
And Thanks for any suggestions at all.


Have you tried going to application monitor >> choose you email program >> right click >> select edit >> then tick allow all activities for this application >> click OK.

OR, have you tried uninstalling and reinstalling Comodo. When you get the option to configure it make sure that automatic configuration (recommended) is selected.

It may also help to know your e-mail program.

Hope one of these helps,


Thanks for the reply Mike. The email program is Outlook Express,I thought I mentioned it but I didn’t, and it also is set to allow all. I haven’t done the uninstall of Comodo as yet because everything else seemes to be working except the part where it shells out to third party programs.
My system is set so that my router is a dhcp server and assigns ip’s and I have NAT enabled. I am wondering if maybe this has something to do with the problem. My browser is set to automatically detect settings and my email uses my browser settings. The email scanner checks and uses the browser settings also, but I am not sure when it checks. If it checks while I am offline it would see as a ip, online would be another though.
And this might explain the error I get when I try to update the AV program, it tell me it failed to connect to the internet service and to check my internet settings and try again. But if I set CPF to allow all, then it works. I am not sure. Maybe the uninstall,reinstall of CPF may work. I just hate to start from scratch again setting things up if I don,t need to.

Hello Lee,

The mos AV email scanners run in invisible mode and somehow CPF do not show the required popup so that it silently drops the connection.
This issue has been addressed and solved in the CPF update of this month.

But you can still solve the problem by trying the following 2 options :

1- Goto Security->Application Monitor and double click one of the email scanner rules(any of them) in Application Rule
2- Click On Miscellaneous Tab and Select “Allow Invisible Connection Attempts” checkbox,
3- Retry receiving the email

If this does not work,

1- Try to deselect Security->Advanced-> “Basic Popup Logic” option and retry.
2- CPF should prompt you anything before silenlt dropping.

Please let us know if it works…

Just wondering do you know when this update will be released. Thanks.


Hi Leebme, I use a nat router and outlook express for mail. In my app. control rules I have 2 msimn.exe rules; 1) tcp/udp in 2)tcp/udp out both allow not trusted
Then I have my av mail scanner (bit defender) vsserv.exe 1)tcp/udp in 2)tcp/udp out
both allow not trusted. Have no problem sending or receiving mail with this setup. Hope this helps.tim

The mos AV email scanners run in invisible mode and somehow CPF do not show the required popup so that it silently drops the connection. This issue has been addressed and solved in the CPF update of this month.
Thanks for the reply. I will download the newest version tonight and also check the settings which you mentioned and will post back here with the results.

Mike: I have tried both ways with the same problem every time. It sounds as though they have a handle as to what the problem is though. I never even thought about the invisible setting.


Well, I am sorry to say that it did NOT work. Both problems still exist. I also downloaded CPF again to see if it was a newer version but it still was the 3/27/06 version.
I can see the problem with the AV scanner being invisible, but when I try to use the program update function it is on top. Of course, the process is in the background. :slight_smile:
Are they going to post the updated files for download with the updater function? Or do we have to wait until some offical release date?
Thanks for the help. I still think this is a great product!!

Hope the update works for you,