CPF Protection changes to Bad after logoff/logon

Hi, this is the 2nd time this has happened to me. Sometimes when I logoff and then Logon again, Security Center indicates that CPF is not running and I see the appended Comodo Summary screen displayed on my desktop. The fix for this is to reboot :(.

I’m Using CPF


[attachment deleted by admin]

I can verify same phenomena with Windows XP Home SP2 running Comodo Firewall

I have two users, user A running as “admin level user” and user B running as “limited user”. When one account logs off (locally, no fast user swithing used) and other logs in Comodo shows a summary screen with all features in off-state. And it is not possible to change them back to on-state, only rebooting the system will fix the situation. This is happening everytime when I switch from B to A (from limited to admin).

It seems that older version (, downloaded 22nd of October 2006) does not have this problem. At least when I briefly tested it it seems to allow user log off/on without any problems.

Problem appears to be independent from Antivirus application running, as I encounter same problem with two computer both having different antivirus in them.

I see this as a major problem, as using the limited accound for daily usage is basic security policy for me (even in my family computers). Any help with this issues would be very welcome as for me Comodo Firewall is the FW of my choice this far.

Happened to me again a day or so ago. I do not use fast user switching. I simply logoff with my admin ID and then logon again. Comodo firewall may or may not be disabled. 95% of the time it is not disabled. Should this not be 100%?

If one of the developers or someone else has an idea what I could do to gather more information the next time this happens, I would sure like to hear from you. Otherwise, all I can do is report when it happens, but that doesn’t help much does it?

WinXP Pro + SP2 + latest fixes
Symantec Enterprise AV
AVG-Antispyware (on demand scanning)
A-Squared (on demand scanning)
SuprerAntiSpyware (on demand scanning)


As I test this using two accounts, account A running with admin priviledges and avvount B running as limited user this happes every time when I logout with account B and then login with account A (that has admin rights). So in my case firewall gets disabled 100% of the time user changes, and it also gets into state where it is no longer possible to turn it on (not even with Admin account).

I’m not using fast user swithing either (running XP Home SP2 with latest patches as stated above). I have listed a ticket to Comodo, and provided some additional information related other security software I’m using.

I can replicate this problem with two computer, both having same OS revision but different antivirus, so it should not be related to that. Quite annoying problem, as other than that Comodo Firewall appears to be best solution regarding my needs.


You might want to look at this thread which seems similar to our problem.


It’s marked resolved, so I don’t understand why support hasn’t contacted you yet. Could it be
a case of right hand not knowing what the left hand is doing? :slight_smile: Although, our problem may be
something totally different. If that is the case, I apologize for my snide remark :slight_smile:

I will try adding a second user on my system and see if I can reproduce what you are seeing.


I added a second user with limited privileges and I cannot confirm CPF being off each time after logging on again. In my case it is still random. I tried logging off and on about 10 times and could not recreate the problem. Since I cannot get this to occur consistently, my feeling is that it may be a timing problem as to when the logoff/logon takes place. When the situation occurs, CPF simply gets disabled.



When I do the following sequence:
login with Admin level account → logout
login with limited account → logout
login with Admin level account

I can reproduce the problem, this far with 100% accuracy. I have tried this few time with both of my computers, and the result is the same (but only 9 tries: 4 in one system and 5 in another, so not strictly speaking a statistically valid result).

The difference in our systems is that you appear to be running XP Pro, and I’m running XP Home edition that has only those two user levels available (“admin” and “limited user”). My understanding is that in Home edition the “limited user” is somekind of hybrid of Pro-version’s “user” and “power user” priviledges. I would prefer to run XP Pro in home also, but have not decided to make that investment as thisfar Home edition has been solid enough.

My assumption is that something get’s stuck when either starting or stopping CF with Home edition “limited user” rights.

And oh yes, Comodo support has contacted me after I filed the case, and they told that they are investigating the problem, and will come up with a patch if they can reproduce the problem. I hope you can test with XP Home also…

I guess my topic (https://forums.comodo.com/index.php/topic,6912.msg50587.html) is a duplicate with this one :-\

Hi Al,

In fairness to the mods (who are all volunteers and do not work for Comodo), it woldbe a full time job to contact everyone who posted a problem when a solution is found, let alone remembering that the solution was posted around a month ago.

FYI, Comodo’s official support centre is at http://support.comodo.com.

Hopefully the fix for this issue will make it into the first beta release of version 3, which is due for public release on April 16th.

Ewen :slight_smile:


Also from my behalf, very high respect to the mods and also to the Comodo coding folks. Making good work with the product that’s given out for free isn’t alway that glamorous. And I fully understand the limited resources regarding the support.

I do not know if that’s me not being able to comprehend with the support site, but I was unable to locate status of my ticket from support.comodo.com. Thus, big thanks to the actives on the forum who have been cross-linking threads and sharing the information regarding the subject.

What comes to my own contribution, that’s not much, but should anyone tell me how to provide better and more accurate testing and debugging data, I’m only happy to spend my time doing that. The firewall is rather good already (actually the best I was able to find regarding my needs), but there’s still room for improvement. And if can contribute and help to make this product gradually better, I’ll try to do that.

Thanks for your kinds words, KSot. :slight_smile:

To check your ticket status, log into the support site and then click on the View Tickets link. From there you can click on the ticket that you titled it.

Should you wish to help beta test, the beta corner is your best location.


So there is no misunderstanding, I was in no way talking about the mods. If I recall correctly, KSot had a ticket open with the support center and I was referring to the left/right hands of the support center :slight_smile:


NP. Sorry for the misunderstanding on my behalf. :wink:

Ewen :slight_smile:

I have the same problem, I’m using version
Last time my computer even froze. :-\

Same in topics:

I’m using CPF on two XPprosp2 decently tweaked machines, one at work and one home, very similar in software configuration; the one at work has also File and Print sharing enabled; I always had this problem with the later.
Fast user switching disabled on both computers.
Therefore, I’ve performed a new install, and found that the problem came back only when I’ve disabled “terminal services”

The issue never was serious because a restart (instead of logoff/on) takes me only about 20 sec.
Have to mention that I’ve never had this problem on the other machine, having also all unnecessary services disabled.
Hope this somehow helps.