CPF Out of Control After System Restore

I had to do a system restore because of problems associated with the removal of Roxio Easy CD/DVD Creator. Up until that time, CPF (.276) was running fine.

After the restore, CFP became so unmanageable that I had to uninstall it. It first starting having problems with Avast Shell, then MS Outlook, then when defrag.exe attempted to run in the background, CFP generated warnings on every file defrag encountered.

Every other program on the PC ran fine. I did notice a couple of things that may be related to the problem. I run Disk Checkup (by Passmark) and it was unable to load. Running it in debug mode, the log file indicated it was unable to find C:.

I went to My Computer > Manage > Disk Management and noted that there is NO DRIVE letter for what should be my primary C: drive. I was unable to assign a drive letter because Disk Management indicated that C: was in use. I tried using diskpart, hoping that I would have more control over actions taken. However, no luck there either. It was interesting to note that although there was no volume letter, it did indicate NTFS, size of drive, Active, Healthy, but not that it was a “system” or “boot” drive.

Windows Explorer recognizes C:, as do all programs except Disk Checkup. I’ve not been able to find a way to get the C:\ reassigned to that volume.

After several days of research with no luck, I saw that CFP had another release (.277). I downloaded and installed, however, outcome was exactly the same. I’m convinced this is NOT a CFP issue, but is somehow tied to the missing volume letter for what should be my C drive.

I’m almost at the point of doing a clean install and starting all over. However, for what seems to be such a minor issue, I’m hoping that someone in the forum has a fix for this.

Thanks in advance for your help.

Don’t know if this will help but take a look at:

http://www.goodells.net/multiboot/notes.htm

Regards,
Mike

Thanks Mike:
I’ll review the links you sent me. I’ve already tried fixmbr and the bootini file without success. Somehow I’m sure the problem is simply a missing C: that got scrambled in the registry during system restore. Maybe I’m being simplistic, but I don’t think that just about nearly all PC operations are running perfectly that this can really be a big deal. I think that programs like CFP and Passmark’s Disk Checkup are looking for C: in that “place” where it no longer is.

Thanks again. SA Jack

I had to do clean install after using system restore with CPF3 installed(Windows Vista) my computer was crashing every 2/3 hrs the report from microsoft support for BSOD was that there was a problem accessing the hard disk which caused the crash.
Have posted a bug report on the forum and a ticket on comodo support.
Sorry I can’t help you.
Dennis

Thanks for the response Dennis:
I guess what’s weird about my situation is that the PC runs great. Other than a couple of programs (CFP and Disk Checkup), everything works great. I just seem to have this missing volume label for C:

If I go into Win Recovery Console and type “MAP”, all drives are recognized by their proper letter. “Diskpart” is the one that shows what should be drive C as having no label, and of course that’s being picked up under My Computer > Manage > Disk Management.

Until the restore CFP was working perfectly. And the restore was prompted by problems related to an uninstall of Roxio Easy CD/DVD Creator.

I’ve tried chkdsk, bootfix, fixmbr with no luck. My C drive only has the 1 partition. I’m lost. I’ve posted here because this forum has some really sharp minds and a genuine willingness to help when they can.

Hi:
I’ve got one additional bit of information that may be helpful in solving this mystery. I did a slipstream of XP SP3 figuring Id do a repair. However, Just after all the drivers were loaded from the CD and the bottom of the screen indicates that it’s starting windows, I got the blue screen of death. It states UNMOUNTABLE_BOOT_VOLUME
STOP 0x000000ed 0x82332030 0xc0000102 0x00000000 0x00000000

Thinking that I may have made a bad slipstream CD, I tried using my slipstream from SP2. That had no problem loading, showing no errors. I figured I made an error creating the slipstream for SP3 because I used the slipstream SP2 as my source data. I think I should have used an original Windows CD. In my case that’s an SP1. So I slipstreamed again and tried to load. However, like the initial load with my first SP3, I got the same error regarding the UNMOUNTABLE_BOOT_VOLUME.

Don’t forget, I’ve got a perfectly running PC with the exception of CPF being able to run correctly and Passmark’s Disk Checkup indicating it can’t find C:.

Any ideas? Again, I’ve run CHKDSK, FIXBOOT, FIXMBR, etc. I wonder if there is a sequence in which these routines should be run in order to bring that missing C:\ back to life.

Thanks again. SA Jack

I was wondering if you had another system restore point you could use but uninstall CPF3 first I think what happen to me was that in some way CPF3 stopped system restore working as it should.
I could not try this as after a couple of crashes I lost all my system restore points.
Dennis

I’m afraid I’m in the same boat. I don’t have any system restore points prior to my last recovery.

It’s beginning to look more and more that I’m going to have to do a clean install. I don’t understand why SP2 slipstreamed CD loads fine, but the SP3 stops and gives me that UNMOUNTABLE_BOOT_VOLUME error. The only difference in the 2 installs was that I originally used Roxio with the MS IMG file. I’m not using CD Burner XP which recommends its own ISO file. By the way, CD Burn XP references CPF as a compatibility with their product. I did not see that initially. Are there still issues that you are aware of?

Thanks again.

SA Jack:

I see that you’ve tried a number of recovery procedures on your system. I’m inclined to agree that there is probably one or more registry entries in which there is a garbled or missing filename path that references C:\ drive.

However, before you perform a clean install, have you attempted the following?:

  1. Boot into Safe Mode and selected “Last Known Good Configuration”
  2. System File Checker (“scannow /sfc” at the command line)

From your description of the symptoms, I doubt either of those will fix your problem. But I wanted to suggest them nonetheless. Yours strikes me as a very unusual issue that I’ve not seen before. And while it appears to very isolated, your posts are appreciated as they might help another user in the future should he or she encounter a similar problem.

Sorry I can’t help you with the slipstreamed problem as it is possibly not a CPF3 related problem you could try posting in the board link below you stand a better chance of having a reply.
Dennis

https://forums.comodo.com/general_discussion_off_topic_anything_and_everything-b1.0/