CPF not removing VPN Ghost Adapter [Resolved]

After changing the VPN connection so that it does NOT set the default route (and installing Comodo Firewall again) I noticed that disconnecting from a VPN connection does not leave a ghost (VPN) adapter in the system.
That was my greatest problem earlier. So Comodo is my firewall of choice at the moment.

Out of curiousity, what VPN were you using? I’ve testedwith F5’s clientless SSL VPN and it works flawlessly and cleans up the ghost adaptor.

Cheers,
Ewen :slight_smile:

Just plain Microsoft VPN client/adapter with NT (Windows Server - active directory) VPN host.
So, basically there are 2 issues…

  1. I changed the option in the VPN connection settings so it does not set the default gateway, and
  2. Comodo Firewall version has changed since my last one.

Could be any (or a combination) of those two. :slight_smile:

Edited 2006-11-10: Ghost adapter can appear under the following circumstances… VPN connection is on (over WiFi connection). If the underlying adapter (wifi card in this case) is disabled, the VPN ghost adapter appears.