CPF keeps crashing after install/reboot, etc.

Well, I tried three different times today (Saturday, 9/9/06) to get the Comodo Firewall working…but each time it failed and kept crashing.

I had not installed any previous version of CPF, although I had downloaded one last night and received my order number and activation code via email. I waited until this latest version was released that supposedly fixed several bugs. I used this link (Comodo Firewall | Get Best Personal Firewall Software for $29.99 A Year), provided by egemen in this thread (https://forums.comodo.com/index.php/topic,2231.0.html). Soon after reboot, a window opened and asked for my activation code, and I used the “activation code” that was sent to me via email for the previous version that I didn’t install. It then recognized and accepted the code, and congratulated me without any problems.

Installation was remarkably quick, and it needed to reboot to take effect, so I rebooted. Comodo replaced Windows XP’s firewall, and Windows Security Center recognized it. The Comodo firewall started in the system tray, and everything appeared to be working properly.

BUT…

within a minute or so after reboot, I received this message:

http://img438.imageshack.us/img438/3045/comodofirewallerrorbk7.png

And when I checked “to see what the report contains”…I received this:

http://img79.imageshack.us/img79/8042/comodoerrordetailsek7.png

I wasn’t doing anything other than simply allowing the computer to start when this error occured.

I tried rebooting a couple of times, but I still kept getting these messages and the cpf.exe process would disappear from both Windows Task manager and Systernals Process Explorer. As soon as I scrolled my cursor over the sys tray icon, it would disappear. Oddly enough, Windows Security Center still said my firewall as “active” and showed Comodo Firewall as the active firewall.

I tried uninstalling, thoroughly cleaning the registry (with CCleaner and Registry Mechanic) of any remnants, and then reinstalling a couple of times, but kept getting the same results: CPF.exe would continue to crash shortly after startup, with the same messages above being displayed. To make sure there weren’t any “left behind” files or registry entries, I even used Windows System Restore feature to take me back to before CPF had been downloaded before I reinstalled.

After it had crashed and I received the error message, I could open Comodo Firewall through the desktop icon as well as Start>Programs>Comodo…and the icon would show in the sys tray and cpf.exe as an active process through Task Manager and Process Explorer…but within half a minute or so, I would receive the above “error message” again. I never received one crash alert from Microsoft’s Error Reporting service (Dr. Watson) during each episode, though.

My resident security software at startup consists of NOD32, BOClean, Spyware Doctor, and WinPatrol PLUS. I am behind a Netgear WGR614 hardware dual firewall (NAT+SPI) router, wired…with wireless disabled. WinPatrol alerted me to both the “startup” and “services” entries, and I accepted and said yes to both.

Any idea why the Comodo Firewall keeps crashing on me? Or what I could do to try to get it to work?

No idea why it crashes, but probably your best course of action is to send the error report to Comodo and let them try to figure out what happened.

Yeah, probably so. Well, perhaps someone with extensive knowledge of this firewall will be able to help soon. Until then, I’ve uninstalled and am back to Windows XP’s firewall. I’m hoping that this can be resolved, because I have really been looking forward to trying Comodo and don’t particularly want to go the Outpost, Look ‘n’ Stop or Jetico route…

The only other thing I can suggest is try disabling these one-at-a-time and see if that helps, in case there is a conflict between one of those and CPF.

This is a complete"shot in the dark" question: are you running a dual core processor? I ask because Outpost Pro is causing grief for a number of people running dual core.

I have the exact same problem.
Error report: http://tbldesign.net/CPF.zip

Yeah, I thought about that at the time…but guess I was just so frustrated that it kept crashing…that I figured I’d just uninstall, tell about this experience and ask here, and then wait until perhaps someone knew what might be causing this and offered a way to help resolve it.

Ya know, I’m not really sure. I have a Pentium 4 with HT (hyper threading) technology, but I don’t know for certain if it is a dual core processor or not. How would I find out?

[b]@tbl,

Thanks…glad to know I’m not alone here…[/b]

Hey sportsfan,

IMHO, the best way to tackle this is to start at the beginning. The following steps should be done with CPF preferably uninstalled, so there is no confusion.

  1. Can you please save HiJackThis.zip attached to this post

  2. Create a new folder, extract hijackthis.exe from the zip and save the EXE in it

  3. Open this folder and double click the EXE to run it

  4. In HiJackThis (HJT) click on “Do a system scan and save a logfile”

  5. Post the logfile here so we can have a look

All this is going to do is to let us know our start position.

The next steps are going to be identifying what could possibly be causing the conflict, if in fact this is a conflict, rather than an intermittent bug. After that, the next step will probably be (unfortunately) uninstalling a pile of stuff, installing CPF, test, install one of the removed apps, test, install the next one, test, etc.

I know this seems like the long painful way around things, but sometimes you have to travel the long, logical route to end up whwere you want to end up. Intermittent bugs are the pits to try and track down and usually the best way is the slow, methodical way.

Hope this helps,
Ewen :slight_smile:

[attachment deleted by admin]

Please do send those bug dumps to cpfbugs@comodo.com or by using send button in the error reporting screen. I think this is related to automatic updater bug. You can temporarily disable automatic updating by deselecting both Security->Advanced->Miscellaneous->Automatically check for updates/Automatically check for certified applications until we fix the problem.

Thx,
Egemen

Thanks, Ewen and Edgemen.

Ewen…I have ran scans with practically EVERYTHING BUT HijackThis! in the past month or so, and I honestly believe it is free of any malware…but if a HJT log can show possibly conflicts and incompatibilities, then I’ll certainly give it a try. BUT…I’d like to try that as a last resort. Hopefully maybe there is a simpler alternative for everyone involved. I’d really hate to have to uninstall/reinstall, etc. many of my programs…would simply disabling them as startups work to get the necessary results as well?

Edgemen…I was wondering, after reading several posts in this forum, if this was possibly related somehow to installing the 2.3.5.62 version WITHOUT having previously installed ANY version of CPF. For starters, I don’t know at the time of download, if an “activation code” is tied in to the particular version downloaded. In my case, I downloaded 2.3.4 from Comodo’s web-site and received the order number and activation code emails…but I deleted that one (2.3.4) and downloaded the 2.3.5.62 straight from your link…which never asked for an email address during the download process - only to enter the activation code once installed, which I did (and it accepted).

So if I download to try it again…what route should I take? Should I download from the Comodo web-site…give my email address again and get a new order number and activation code…use that, and then “update to the latest version” (which seemed to work for a few people). Or download the latest version…use the same activation code I used before (I have completely uninstalled Comodo and used a restore point to prior to installation)?

Thanks

If you can send the report we could be sure. Do you have super ad blocker installed? Many crashes that have been reported so far are always because of SABSEH.dll module of that program.

But please send the bug report CPF generated so that we can immediately debug and fix.

Thx for the cooperation,
Egemen

Hi Edgemen,

Well, I don’t currently have Comodo installed. I could reinstall and send the report once it crashes again, but I didn’t save the report or anything.

But that’s also why I asked if I should download the version from the Comodo web-site and give my email address again and get a new order number and activation code. Then, use that code and “update to the latest version” (which seemed to work for a few people)? Or should I download the latest version from your link and use the same activation code that I used before? If I can get it to work without having to recreate the circumstances that causes the bug, that would be great for me…even though it may not be for Comodo in order to get to the bottom of the problem… ;D

As for SUPERAdBlocker, no, I don’t use that program. I had SUPERAntiSpyware insatlled for a very short time, but removed it and used my registry cleaners (CCleaner and Registry Mechanic) to clean out all remnants from it…the same as I did with Comodo after I uninstalled it (and before I used Windows System Restore).

The resident security software I have are NOD32 (anti-virus), BOClean (anti-trojan), Spyware Doctor (anti-spyware), and WinPatrol PLUS (IDS/startups manager). I’m also behing a Netgear WGR614 hardware dual firewall (NAT+SPI)/router wired, with wireless disabled. The current Hosts file is the original Microsoft hosts file. All other security software is on-demand. HTH

SportsFan

Sportsfan,

I wasn’t suggesting HJT as a check against malware, but more as a guide as to what is running on your system.

You could disable them as startup items, but you will also need to look at what are running as services, and all possible areas of auto startup. It may end up being easier to uninstall/reinstall.

ewen :slight_smile:

HI Ewen,

OK…so what would be better then for you/Comodo then?

For me to reinstall the 2.3.5.62 version from your link…using the same activation code that I was given…see if the problems occurs again (which I’m guessing and almost certain it will)…and then send the info that is contained in the Bug dumps/log/error report?

Or…

Run a HijackThis! log, and send you the results?

I think just reinstalling, without changing anything else, isn’t going to do anything other than confirm that there is an issue on your PC, whether it is a bug or a conflict would still be up in the air. The only thing it would rule out, assuming the new installation worked, was a corruption of the original install file, but I think this is unlikely.

I’d still like you to run a HJT scan and post the logs. I’ll start searching based on the logs for possible conflicts. Egemen has already found a conflict with a DLL that is part of SuperADBlocker. Hopefully we’ll have the same degree of success.

Cheers,
Ewen :slight_smile:

^SuperAD Blocker you say… Ohhh… That would of been nice to know before going to all the trouble of uninstalling v2.3 and reinstalling v2.1 (:WIN)

Hi Sportsfan,

had exact the same issue. In my case I found out, it was “rrshell.dll”, a part of Regrun Platinum module “RunGuard” conflicting with cpf.exe and cpfupdate.exe.

From Regrun helpfile:
What is the “rrshell.dll”?
This DLL is used to trap file execution.
You can see it in the Start Control, “Windows Core Components”, “Shell Loggers” tab. This DLL is required to use RunGuard in auto mode.
If you are being asked by WatchDog about “rrshell.dll” you should decide do you want to use RunGuard in auto mode or not.

In your security software, I would say, BoClean and/or WinPatrol are acting the same way. Nod32 and Comodo don’t conflict on my machine.

I solved the problem by adding cpf.exe and cpfudate.exe to the exlusion list of RunGuard. I persume BoClean and WinPatrol have both this option to prevent them from checking exluded files - worth to try.

Good luck,
Daxx

SportsFan,

Do you us Windows2000 Pro?

If you do then yours might be similar to mine. And you might then be able to keep CPF working (as a temporary work around), by turning OFF the automatic updates. And NEVER run the “updater”.

On mine, I get the same screen as you, but once I got these changes done it runs fine. Updater is not needed for a while anyway, since we have the latest version, and Egemen has our bug reports to use for future repairs.

Hi Ean,

No, I use Windows XP Home SP2.

I didn’t send in the bug dump/log/report…and I guess I’m just going to wait until I know for sure exactly how they want me to approach this before I decide to install again…

What we prefer is that you install CPF, observe the crash, send the bug report to us so that we can debug and fix. Otherwise, we may not be able to reproduce your issue.

Thx,
egemen

Well, SportsFan, you might just try turning off Updater, as I said when you next try it. It might show it to be only a matter the updater, and it could not hurt.