CPF ISSCRIPT.msi installation error

Tried to install CPF yesterday on a new WinXP Pro SP2 PC (fully patched) and during the InstallShield extraction recieved the following msg:

[b][i]An error occurred while downloadong the file http: //www.installengine.com/isengine/isscript.msi. What would you like to do?

Options were: Retry or Cancel [Retry did nothing][/i][/b]

I fixed the problem by going to EITHER:


and downloading either:


(Contents are the same)

Ran the isscript.msi file within the zip & tried to install CPF again … which worked aOK.

Looking at my Program Files/Common Files/InstallShield, I had v6, v8 & v9 installed by previous SFW installations, but not v7 used by CPF.

OK, given the above error msg it would appear that the isscript.msi file is either missing or corrupt in the Comodo PF installation file. Or prehaps there’s something wrong with how the IS package was built/defined.


G’day Baz,

I had a similar issue installing CPF but I had versions 6, 7, and 10 on my system. The error I was getting was a “1608 driver instance” error. The only way around it was to remove the existing installshield engine versions and install ANY other version. I installed version 9 runtimes and everything installed OK.

I don’t think this is a version-specific installshield error within CPF, I think it’s an installshield error. Macrovision themselves don’t know what causes 1608’s, but I’ve found more and more occurences of them happening as peoples PCs get more and more cluttered.

Why installshield don’t clean up properly after themselves is beyond me!

Hope this helps,
ewen :slight_smile:

G’day Ewen,

This was the 1st time I’ve ever experienced an IS specific error when installing some new SFW … and I have installed a lot of SFW over the years. Maybe I’ve just been “lucky” :wink:

For me, I didn’t doing anything else other than simply run the isscript.msi I downloaded the IS site & rerun the CPF installation pgm.

Looking at the IS directory in Program Files/Common Files AFTER CPF was installed I don’t see any IS v7 related files.

I posted this primarily so that other new CPF users would know what the solution was & for the CPF developers to, maybe, review the CPF installation package.


You are 100% right. this is an installshield problem that is causing us issues now. We have already started to implement a different installer.