cpf.exe taking up a lot of cpu time

So far so good with this homefirewall!

However sometims cpf.exe wants to take up a lot of my cpu time and jam up the system.

When playing online games it is really bad. It usually subsides after a while.

Can I regulate how much cpu usage it can use? Should I?



This may be due to the logging carried out by the firewall. You could try disabling logging to see if there is any improvement.

In network monitor right click any block and log rules and select edit. Uncheck the box ‘create an alert if this rule is fired’.

You can always turn this back on later if you wish.

Another option which can help and will still allow you to view some log events is to make the log file itself read only:

Log Files usually at: C:\Documents and Settings\All Users.WINDOWS\Application Data\Comodo\Personal Firewall\Logs

Right click the file and make it read only. This drastically reduces the drain on your system in most cases. Worked for me and many others.