cpf.exe 97% CPU Time & more...

Running CPF Pro 2.4 .18.184 (CCADV 3.0) on WinXP SP2, Symantec Antivirus 10.2 Corporate edition.

  1. Very often the cpf.exe will get to 95-97% and needles to say my computer becomes not responsive for a minute or so. What gives?

  2. I’m logged in as a domain user who is in the local administrators group (i.e. I do have admin rights on this machine), but if I try to run the updater - I get “You are required to have administrative priviledges…” message. Why?

Hey Grandpa,
what a wonderful name you have ;D

Here are some links which might help you (cpf.exe - your problem / cmdagent.exe - for additional input / ideas):

Version 2.4 - cpf.exe and high CPU

Version 2.4 - cmdagent.exe and high CPU

As I’ve never had any such problems (cpf.exe and cmdagent.exe always on 0%) I’m afraid I can’t be of more help.

I’m afraid that’s how it is. You cannot update CPF if you don’t have administrative priviledges.
Why is that so??? - I don’t know for sure but I assume that it’s rather Microsoft’s fault than Comodo’s. To update Comodo’s BOClean you also need admin rights.
The BOClean manual (http://www.comodo.com/boclean/supboc.html) describes why it doesn’t work with limited accounts and even presents a way to circumvent this problem. Maybe this is also true for / also works with CPF (if you’re admin is as nice as to grant you the privilege).

I hope this helps until someone can give you definite answers to your questions.

I would bet that the rights of the Domain Admin are not being passed on to the local Admin account somehow. There could be some Group Policy set above you that is stopping it.


I think I wasn’t very clear on the #2 issue - the domain user I’m logged in with IS in the Administrators group on the local machine. Therefore it is not a restricted account, but a full-blown local admin (and anything else that requires admin rights on the local computer acknowledges it… except Comodo)!

Now, if Comodo tries to verify admin credentials against the domain - sure, I’m not a domain admin. But it shouldn’t do that as we’re talking about Comodo on the local machine.

You are right about it being able to use the local admin account. I know Panic (MOD) is using it on the company network that he admins. Don’t know if he had to do anything special or not to get it working.


Sorry, you were very clear on the 2nd issue; I just didn’t read your post thoroughly enough :-.

The only reason I can image for you not being able to update CPF is what jasper already assumed:

However, it’s quite strange that CPF is the only programme that does not acknowledge your local admin rights.

Beats me!

Hope you’ll be helped soon; if I get another idea, I’ll let you know.

I just did a bit of reasearch in the forums and found a very interesting post (unforunatey for an older version - but maybe the problem still exists):

I now can finally approve that a domain user having local administration rights, cannot activate or update the firewall software. It only works for any user in the local administration group. So, now my created local admin user was able to activate it.

If you’re interested in reading the whole thread:

This might also interest you:

Hope this helps.

Depending on the Windows version, there are different permissions available to each user group; in this scenario, even an “Admin” may not have much more than Power User privileges. This would probably be the case with the scenario that grampa quoted from.

I have been surprised in the past that even tho I was an Admin, and in the Admin Group, I still lacked some permissions, and couldn’t give them to myself. Bummer! :frowning:

I don’t know specifically how all this would come into play with Comodo updating, but that might be something to look into.


Hi Grandpa,

Correct me if I’m wrong, are you running vista? I don’t think cpf is certified for vista.


Guys, I appreciate your opinions, but please, at least read my post, before posting:

Running CPF Pro 2.4 .18.184 (CCADV 3.0) on WinXP SP2,

The bottom line so far:

  1. Grampa - 10x for the links (ain’t your nick great too :Beer).

  2. Domain user, even if in the local Administrators group might not have enough rights to run the updater. From within the application that is, because it can still run the cpfupdat.exe stand-alone just fine. Clearly a Comodo bug. Another option is to run cpf.exe as a local machine user with admin rights.

Hey Grandpa,
glad to hear that - at least - you finally understand what’s going on and found a way to work around the problem. Whether it’s a bug or intention or Windows, group policies…we’ll never know. May it’ll all be fine when v3 is released.
Please stay loyal to CPF (CNY).
Please forgive forum members who miss / can’t remember a(n impotant) detail - has happened to me and probably everyone else here who read many (long) threads each day (:WIN)
And Grandpa… I’m really made up that I’m no longer the “oldest” bloke in the forum. ;D
grampa :Beer

Will you file a ticket with Support: http://support.comodo.com/ providing them with complete details of your situation and work-around? This way we’ll be sure they know; if it’s something they consider necessary for some reason, or a bug to be worked on, will then be known…

Please keep us posted as to their response.


Unfortunately it seems that I still have issue #1 (:AGY)

All 4 log options are unchecked (though I can still see log entries being made in the application, so i guess the options really mean “don’t flush to disk file”…)
I have the dll injection unchecked as well.

Welcome to my thread: Firewall Still Logs After Disabling. In the meantime, the best workaround is to set logs.log file to read-only as per the one of the links Grampa pointed out. I think I was the first one to discover this trick.

Don’t. That only potentially affects cmdagent.exe, never cfp.exe.

Hey Grandpa,
I know this won’t help you a bit. However, I thought I’d share.

  1. CPU time for both cpf.exe and cmdagent.exe is ALWAYS 0% (at least whenever I check).
  2. Just tried to disable logging. Result: no log entries at all.
    Re-enabled logging: logging back to normal.

What might I have done that you haven’t ? - Installed CPF in Safe mode.
Maybe that’s the only, if unsatisfactory solution to your problem: Do a clean uninstall and re-install in safe mode.

Otherwise, I’m afraid, I’m running out of ideas.
Hope the problem will NOT persist with v3.

Now that’s one thing I have not done with CFP! I’ll try that now. If that doesn’t fix it I demand a refund.

Fingers crossed!

Where’s my $0.00 back? >:(

Uninstalled, cleaned files and registries, installed CFP all 3 in Safe Mode. I still get the logging problem after it’s supposedly disabled. However, there’s a popup that I had forgotten because it only comes up once per CFP install. Maybe it’s related? Nah, couldn’t be.

[attachment deleted by admin]

Never seen it before ???
Beats me.
Btw, pm me your bank details. I’ll sent you the $0.00 :smiley:
I wanted to go to bed an hour ago. I should really go now. I can’t bear all the cheap jokes and nonsense I’m writing tonight.
Hope this problem will be history on monday (fingers crossed).