CPF consistently fails pcflank.com leak test [Resolved]

The title says it all. CPF is running. Advanced settings are set to default. I am not getting any popups. This is somewaht of a cause for concern. CPF is supposed to be the only firewall that passes this test. Can anyone suggest a reason and a solution for this?

P.S. I am also not sure it passed CPIL leaktest from the Comodo site. The test result said explorer.exe not found, but I also didn’t get a popup the way the site said I should. What does this mean?

I get conflicting results. Hi, I’m running CPF v2.3.2.21 and tried PCFlankleaktest. I made sure “Monitor parent application leaks” option is enabled. And I made sure “Skip parent check” and “Skip advanced scurity checks” option for my browser were not selected. Below you can see what I get.


http://img303.imageshack.us/img303/8886/lt01li9.th.jpg

I chose Deny on the popup but the leaktest app says it failed before I can hit Deny. Also when I go to the webpages leaktest results, the text I used for the test is not there. The only text there is the text I used when I tested ZA Free which failed. Even though the leaktest app says failed the test page results doesn’t show that it failed. Hope this helps some.

What the test reports is wrong. CPF is cathing the attempt before sending it so nothing to worry about.

I figured CPF was actually passing (dispite the apps message) since I get a popup and the text I used did not show up on the test results webpage. :slight_smile:

BTW, I tried cpil.exe and CPF caught it allowing me to deny.

This is interesting, will try it on my desktop…

Yours truly,
DoomScythe

I just tested it on my desktop and it seemed that CPF did manage to raise an alert that says PCFlankleaktest was trying to use IE to connect to the Internet. My situation is somewhat similiar to Wheelie4.

The PCFlankLeakTest says that my firewall (CPF) failed the leaktest even before I hit the Deny button. After denying everything, I tried to access the results site but my browser was unable to display it. I think it is because CPF has blocked access to that particular address (though I might be wrong here). I personally don’t think CPF failed the leak test, but I will run it a few more times and get back here.

Yours truly,
DoomScythe

Maybe I should uninstall and reinstall. The question is whether the permissions are stored somewhere so that the new installation will remember them.

Erm, I don’t know about them but I may try to locate them tomorrow (it is really really late here). But seriously, re-installing a firewall can be quite a hassle, considering you have to click 30 or so ‘Allow’ or ‘Deny’.

Yours truly,
DoomScythe

The CPF settings are stored in the Registry key HKLM\System\Software\Comodo and its various subkeys and values. Exporting this key would save these to a file (e.g., saveCPF.reg). Then to restore them, you could delete the subject key after reinstalling the program and then double-click the reg file or import it into the Registry.

HOWEVER: this is a very dangerous operation and should be used with caution and only if you are comfortable messing around in the Registry! You could disable your whole system if you slip up!

Unfortunately I can’t see any other way of fixing an incorrect permission that is allowing the leak that fails the leak test. If you have an idea I am all ears (or eyes in this case).

PCFlank tests are notorious for skewing results . And , leak tests are simple to pass in this day and age . However ; that said , I am confused as to why the leaktest on that site shows failure . Anyone have a solid answer as to what needs to be done , if anything ? Now I am curious as to why this occurs . Extremely confusing . If it is wrong , someone please explain . I will check it out myself to see what is going on but , I have seen no solid answer to the original poster’s question .
Thanks in advance

Hi,

Just did the quick scan and stealth scan using the Sygate Online Services, and Comodo passed both of them.

That is great Justin . Now , we are talking about a leaktest at PCFlank . There is the problem . With default I can pass Sygate . I find the leaktest is giving me trouble now also at pcflank . This is certainly interesting

That test does not show correct results and misleads the users. If you see a popup from CPF including Pcflankleaktest.exe in the security considerations, then you passed no matter what the test reports.

Ofcourse unless you allow. And try different words each time you use the test. Because the site stores your text if you allow, and when the next time you visit the site, you will see your text there.

Thank you for that answer . However , as good as it might be , it still escapes me as to how it is a solid answer . The only reason i say this is because I used their leaktest against another firewall and it passed . I must admit though , that I have used many against their leaktest and they all fail but one . if the one did not pass as well , then I would say ok . But , one DID pass . This being the case , may I ask how you might know that the test result is skewed ? No argument here as I know their tests stink . Long ago it was a nice site to test things . For the last year or more , it has been nothing less than a joke . Thanks again for the input . I am just trying to understand what is at work here and why .

Falkor

Lets analyse what a leak test is: Its a piece of code that runs on your machine, that tries to defeat your firewall by trying to submit some data into a website.

Now, that code has some logic in it that show either passed or failed window message to the user. This logic is based on something that the author thinks valid. Well, we all know there are more than one way to solve any problem :wink:

The question is not what that application tells you cos the logic that determines whether its passed or not could be limited, but whether the data has been leaked or not.

Do you see the data leaked? If not, then the the firewall passed the test. No matter what their dialog box says.

melih

Thank you Melih my friend . Nice answer and easily understood by me . Did I see the info leaked ? All I know is the typed message was shown as a leak . It is my personal belief that based on what a leaktest actually is , Comodo really passed . I just do not understand why they claim it failed . I have always thought it is the way they produce the test and NOT the firewall itself . I certainly believe in this firewall MUCH MORE SO than in any test at pcFlank . Just wish I knew what the real deal is . Thank you for the answer . I think that is as close to being solid as possible based on the facts as they are known .
KEEP UP THE GREAT WORK !!!

Thank you Falkor :slight_smile:

Melih

Do you have any ideas about my problem (the one that started this thread)?

Hi r2baruch,

I assume you always enter different words, you always see what you write on the test site and CPF never warns you. This is the only case that is considered to be failed. The test may say “You have failed”. But this is not a case if CPF shows a popup.

Lets do the following:

Please delete the following key:
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Personal Firewall\AppCtrl\IPC and Restart your computer(If you are using BETA, you wont be able to delete it without killing cmdagent.exe from the task manager).

After you restart(Dont forget to restart you PC), run the test and paste us all the popup screenshots you see so that we can see what is going on.

Thx,
Egemen