CPF Blocks Netgear Print Server

I have a Netgear print server on my home network. CPF blocks all print jobs to the HP printer connected to the print server. While CPF is running, they simply show as spooling until they time out. The instant I shut CPF down, the spooling print jobs hit the print server, then the printer, and print.

I have no problem printing through a VPN to a network printer at one office. I also have no problem printing to a high speed Canon network printer at another. So, the problem is not all network printing, just printing to the Netgear print server.

I added a trusted zone with the entire IP range for the home network, to no avail. I also added a trusted zone with just the IP of the print server, also without effect.

I have enabled logging and the log file shows that access is granted to the print server, although that obviously is not happening. The log also does not show anything being blocked. The log says:

Date/Time :2006-06-25 16:48:50
Severity :Low
Reporter :Network Monitor
Description: Information (Access Granted, IP =, Port = printer(515))
Protocol: TCP Outgoing
TCP Flags: SYN
Reason: Network Control Rule ID = 0

My computer is at; the print server at

Any ideas why CPF is causing the problem or what to do about it?



I see nobody has an answer to this problem. It’s a deal killer for me. I’ve tried everything I can think of and I can not print with the network monitor on. Oh well! Back to Zone Alarm.


Egemen can you please check this?

Hi guys,

As you have pointed out, this problem seems speficic to NetGear print server. According to the logs, nothing is being blocked. I will try to reproduce it here to understand the possible reasons.

But you can try to disable following options to see if the issue is solved:

Security->Advanced->Secure the host while booting
Security->Advanced->Secure against trojan protocols
Security->Advanced->Monitor DNS Requests


I have the same problem (can’t print but no logs as to why) with a Zonet ZPS2102 print server. Interestingly, I tried CPF when the problem devoped after an update to the latest version(s) of ZoneAlarm Pro.


My NETGEAR PS121 PrintServer (USB : ethernet) works perfectly on my network. I can access it from my wireless notebook which has Comodo Firewall ( installed.

The print server was working before I installed CPF, and continued to work afterwards, with no special setup on my part. I have the PrintServer set up as a static IP in the 192.168.0.xx range, along with my wireless PC (also static IP address @ 192.168.0.zz), and the wireless router @

I’m wondering if this has anything to do with the “Appletalk” protocol that the Netgear PS101 print server uses, and according to google so does the Zonet ZPS2102, but apparently not the Netgear PS121 which is noted as working.

Just a thought?


I have similar problem that I can’t get a printjob trough the Netegear Printserver PS105.
I get error message “Cannot connect to print server” all the time. IP number is within the

Have given up last update of Zonealarm which made my computer behaving strange with
no solution from Zonealarm. It took many, many hours with try and error but with no success.

Hope we have a quick solution so I do not need to look for another firewall sloution.

Hi guys,

Please disable following 2 options:

  • Security->Advanced->Secure against trojan protocols
  • Security->Advanced->Secure the host while booting

Thats the only reason that CPF can block something

Hi guys,

Please disable following 2 options:

  • Security->Advanced->Secure against trojan protocols
  • Security->Advanced->Secure the host while booting

Thats the only reason that CPF can block something[/color]

I have both disabled, but still can’t print.


Could be worth pursuing, but I have no idea how to do any changes in the Zonet PS. Thanks.


I know this is not really any help as far as a solution…only offered as a comment.
Up until about a month ago I was using CPF with a Netgear FR114P router with print server and was printing with no problems from four networked pc’s. No special configurations to the router or to CPF were required. BTW, I already had the Netgear and printer in place, configured and working before downloading and installing CPF.

a final thought…I keep the “application” list in CPF cleaned out of former and seldom used apps so I don’t recall if there was an entry for print spooler in it or not but you might check and if there is, you might want to remove it, send a print job and grant new permissions.

I have the same problem with CPF not allowing printing to a Netgear print server. I cannot print with the Network Monitor on. I tried disabling:

  • Security->Advanced->Secure against trojan protocols
  • Security->Advanced->Secure the host while booting

Still no printing. Any resolution to this problem? Many, many thanks!

CPF log file for problem printing to Netgear print server:

Date/Time :2006-08-02 02:08:34
Severity :High
Reporter :Network Monitor
Description: Blocked by Protocol Analysis (Invalid Flag Combination)
Direction: TCP Incoming
Reason: SYN ACK PSH is an invalid TCP flag combination

Any ideas?

Which server sends this packet? Netgear server? The problem is that, even though there is
no statement in the standards classifying SYN/ACK/PSH itself as invalid,
the operation that PSH demands – immediate transmission to the
application – is explicitly forbidden during the handshake [RFC 793,
pg. 30]. So CPF is strictly enforcing the RFC standards. We have put an option to disable this in the upcoming CPF 2.3 build, so i hope it will solve all problems about such non-standard protocol implementations.


I have installed the new beta. How do I implement the option referred to above? Thanks.


Hi Jim,

You need to disable :
Security->Advanced->Advanced Attack detection and protection->Do protocol analysis option. Let us know if it solves your problem.


I am having a problem with my print server, I ahve read through the problems and replys posted here and I have seen no real solutions.

The server and its software do their own configuration, I can see the server and the printer attached to it. This print server is an IOGEAR MF Print/Data Server, this server connects USB devices via the CAT 5e connection at the router to the computer(s).

The software setup multiple protocols for TCP/IP, IPP, Raw TCP, SMP/CIFS, FTP File Server. UPnP is also enabled.

The problem is that when I print the output goes to the print queue and doesn’t print until I connect via the USB port on the computer.

I not sure what further information is needed