CPF Blocking PC Magazine's HD HeartBeat

I am using CPF on Windows XP Pro SP2.

I am also using PC Magazine HD HeartBeat. The version I’m using is actually a beta, obtained directly from the author, but I’m assuming the problem will occur with the current release ( as well.

HD HeartBeat has two components: A background service and a GUI client. The service queries hard drive S.M.A.R.T. data, and broadcasts on a UDP port. The GUI client takes in that UDP broadcast, and displays the S.M.A.R.T. status. When everything is functioning correctly, this allows you to run the HD HeartBeat service on any computer in your LAN, and monitor that computer’s drives using the GUI client. In other words, the GUI client will show you not only your local drive’s status, but that of the other computers on your LAN, if any.

Before I installed CPF, HD HeartBeat worked fine–my GUI client would correctly display the local drives, and the drives on my notebook, elsewhere on the LAN. But with CPF, strangely, I can only see the notebook’s drives–and not my local drives!

I’ve tried everything with the application rules: Skipping the parent application check, allowing everything, deleting and recreating them, and so on. And I’ve done this for both the HD HeartBeat service, and the GUI client. And beyond that, I’ve even turned off the application rules entirely.

But nothing helps. Even with all application rules disabled, I can still only see drives from across the LAN, and not my desktop’s local drives. I’ve also tried stopping/restarting the HD HeartBeat service and GUI client–to no effect.

To make things even more confusing, I can see the desktop’s drives from the notebook–meaning that the desktop’s HD HeartBeat’s service is not being blocked from broadcasting (at least not completely). So, I can see my desktop’s drives using a GUI client from across the LAN, but not using a GUI client on the local machine itself. The notebook is not running CPF.

I have network control rules fully disabled. Component control is in learning mode.

Absolutely nothing shows up in the CPF log. If something is being blocked, it’s being blocked silently and mysteriously.

Please advise, if you can.

The current stable version has a bug and don’t display uncommon blocked traffic. At the next beta that will be released this tuesday it will be fixed. Just wait for a couple of days (:WIN)

I do have the Secure against trojan protocols option enabled. Does this have something to do with it?

I don’t understand the reply in any case; it would be nice to know what (“uncommon”) traffic CPF is blocking, but knowing why would be even better. Even when I configure CPF not to block anything, it’s partially blocking HD HeartBeat somehow.

I guess I’ll just wait and hope. Thanks for the reply.

There is a bug on the stable version that don’t display all the traffic that is blocked. (for example it blocks the search through the Kad network of emule). And this bug is related with another that blocks some types of fragmented packets even if you check the option to allow them.
the current beta displays all the blocked traffic, but still blocks some fragmented data.

And it can be the option “secure against trojan protocolls” that cause your troubles. Try to disable it, and see what happens. Also you may need to check “skip advanced security checks” for that application.

That feature is problematic and will be rplaced with a better defense mechansm in the future. You can try to disable it and retry to see if it was the cause. does not show blocked packets which fail to pass the protocol analysis. BETA versions show though.


I just installed the beta. Of course, I uninstalled the prior version first. So now I have to start all over again, and reconfigure everything? OH HELL NO! I didn’t respond to 30,000 popups for nothing!

I also loved how the beta’s installer insisted on appending “Comodo\Personal Firewall” onto whatever directory I selected for installation. I did have CPF installed in “C:\Program Files\Comodo Personal Firewall” previously, but since I couldn’t reinstall to that location, I now have a bunch of dead links (mainly shortcuts, but also the workaround I had in place for the lack of a regular CPF tray icon).

Well, whatever. I give up. BTW, the problem was not the trojan protocol setting.

Thanks anyway.