CPF allows short emails, blocks long ones?

Hi all,

I’ve been using CPF for some weeks now and discovered an unexpected and odd effect.
I use Thunderbird on Windows XP SP 2. After having CPF on for a while, I realized that Thunderbird was failing to send some emails. Anything small gets through OK. For emails above some size limit, Thunderbird reports “SMTP server not responding”. When I turn off CPF, I can then send the same emails normally.

CPF has updated itself to the most current version, There is no problem receiving mail of any size. The problem doesn’t seem to care if the outoing email is a long, simple text email or an attachment. I haven’t taken the time yet to determine what the magic number of bytes is that triggers the trouble. The Application Control Rules say that Thunderbird is allowed both in and out.

I’m trying CPF because I was unhappy with the Symantec product I purchased. There seem to be many good things to like about CPF, and I was influenced by the great review in PC World. My short term workaround is to uninstall CPF. I’d be happy hear an explanation and solution that involves using CPF.


CPF does not have such a restriction. Do you have an AV?
If you are using an antivirus which scans your emails, try to enable “Skip advanced security checks” option for the email scanning module of your AV by going “Security->Application Monitor”, double clicking the rule for email scanner and selecting “Miscellaneous” section.


Thanks Egemen.

Yes, I didn’t think this was an intended behavior in CPF. I don’t use a real time AV on my email, precisely to avoid this kind of problem. I manually run CA AV and Windows Defender periodically. Used to use Symantec, but it’s no longer on my system.

Are there things in Windows that CPF might interact with, that would explain why the problem goes away when I set CPF to “allow all?” I’m beginning to suspect the problem is in Windows rather than in CPF.

CPF may be causing thunderbird to timeout somehow. Can you try to enable “Skip advanced security checks” option for thunderbird and see if the problem still exists?


Thanks … I’ll check and get back. Saw a different interesting event this morning, which I’ll post in a new thread.

I tried that, and while I was at it, I also tried “Allow All Activities” for Thunderbird. Neither made any difference to the symptoms.

Thanks for the suggestion. I’ll be happy to try any others you have.

I have this problem too with Thunderbird. The only thing that helped was making a rule to alloww outbound TCP… That did the trick but I worry that it is not safe to do…

Would be nice if Comodo could sort this problem out. Thunderbird is not that strange :slight_smile:

The safe thing and such did not help at all. and it’s absolutely not my av program (NOD32)

Another solution I seem to have found:

I deleted the TCP out rule for all prograams and went into Thunderbird settings at CPF and skipped the parent, now a long email went out without a problem too… Maybe the solution, bujt again: is it safe?

Thanks ESM. I noticed that CPF set the parent for Thunderbird as Internet Explorer, which doesn’t make sense offhand. I didn’t find any information in the Help about the parent of an application, but I skipped it for Thunderbird.

I’ve also had this problem and again whilst I cannot be specific about the size of attachment that cuts out. I can say that attachments of 9 or 10 MB fail to get through whilst ones of the order of 1.25 MB do get through.

So has has anyone got a definitive answer please. I use Thunderbird, but I was also having problems with the previous version?


This may be another example of ICMP fragmantetion messages. Please try to follow the instructions in the following post


Or alternatively, you can download and install BETA version, which has this rule by default.

It is available at https://forums.comodo.com/index.php/topic,1047.0.html


Thanks for your reply.

I am sorry I should have made clear that I am using version Beta CPF, so, If I understand your reply correctly, the rule you are referring to is already in this version?

Any other thoughts?

Many thanks


Oh yes. That rule is included in the beta version. what do your logs say?