CPF 3 is messing with MS Activesync. [RESOLVED]

Just installed Version 3 of CPF and it won’t let me use MS Activesync. All other apps are fine but Activesync won’t work unless I completely dissable the firewall.
It’s not remembering my answer to the popup when I click OK to “Allow this request”.
It just keeps comming back.
The firewall sees it as a safe application but something is not right.

http://i48.photobucket.com/albums/f217/StuartB4/untitled-2.jpg

Any help would be appreciated.
Thanks

Have you tried making a Trusted Zone for that IP range (169.254.2.1–169.254.2.255)?

Here are the ports from MS that need to be allowed for proper working of ActiveSync thru a firewall:

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

ActiveSync 4.x requires the following Winsock Transmission Control Protocols (TCP) to be available:
• 990 (RAPI)
• 999 (Status)
• 5721 (DTPT)
• 5678 (Legacy Replication)
• 5679 (Handshake & Legacy Replication)
• 26675 (Airsync)
If socket port filtering occurs on any of these Winsock ports, ActiveSync does not synchronize with Microsoft Windows mobile devices.
MORE INFORMATION
Winsock ports can be filtered by firewalls and by some routers in a networked environment. They can also be installed locally on the desktop system running ActiveSync. Network administrators may filter Winsock ports as a security measure, to limit the types of connections that can be made to the server. If synchronization is being attempted on a network where the above ports are blocked, ActiveSync fails to synchronize with the connected Windows mobile devices.

In most situations, the Windows mobile device connects to the client. However, if ActiveSync synchronization does not begin, the connection eventually times out.

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

jasper

Thanks. I assume I do that in “My Network Zones”
Do I need to add the port numbers you listed above in the “My Port Sets”

Yes make a new Trusted Zone(use a range of addresses) and the ports could be done in the My Ports Sets and used in the rule. When you are setting up the rule make sure to check to log so you can see what is happening. Also, you might have to give the firewall a little time(couple of minutes) to enable the rules before they work or you could reboot to be sure.

I did a search on google and here is better info for setting up ActiveSync

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
[b]
You may use the following information to configure the firewall software on your PC/Laptop if you are having trouble syncing your Windows Mobile device…

ActiveSync uses the following programs: WCESCOMM.EXE, WCESMGR.EXE, RAPIMGR.EXE, and CEAPPMGR.EXE.
ActiveSync uses the following TCP and UDP ports (this information may change in future releases of ActiveSync):

Port number: 990
Direction: Inbound
Type: TCP
Description: Remote API (RA)PI

Port number: 999
Direction: Inbound
Type: TCP
Description: Status

Port number: 5678
Direction: Inbound
Type: TCP
Description: Legacy Replication

Port number: 5679
Direction: Outbound
Type: UDP
Description: Legacy Replication

Port number: 5721
Direction: Inbound
Type: TCP
Description: Desktop Passthrough (DTPT)

Port number: 26675
Direction: Inbound
Type: TCP
Description: AirSync

ActiveSync uses the following TCP/IP addresses: 169.254.2.1 for your PC and 169.254.2.2 for your Windows Mobile 5.0 device.
Port number: 26675[/b]

XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

jasper

Thanks a million jasper2408.
Did as you suggested and everything is working great.
Fast response and very helpful.
(:CLP) :BNC :■■■■

Glad to see you got it working StuartB. Have fun syncing. ;D

I am going to go ahead and lock this thread. If you need it reopened then just PM me or another MOD and we will be glad to reopen it for you.

jasper