CPF - Failure to install

When I tried to install the newest x86 version on my system (CFP_Setup_3.0.14.276_XP_Vista_x32.exe), the installer copies the program files to the intended directory, then the installer asks me to reboot. It completely skips the driver initialization phase, resulting in a non-working installation. I see that “skipped” screen very briefly, but not long enough for any human to read. When I reboot, CPF doesn’t launch. When I try to manually launch it, I got an error message stating the program is not correctly installed, and to run the diagnostic; which also doesn’t launch.

What could cause that? I’m running XPSP2 32 bit with the latest updates, I am running no resident protection of any kind. I’ve closed everything possible, I’ve tried to install in Safe Mode. Same thing. I’ve following the uninstallation guides in these forums, and that doesn’t help either.

I downloaded the full setup file. I tried the setup file on a fresh XPSP3 install (virtual machine) and it works fine - copy files - initialize drivers - prompt to reboot. If I didn’t test it on the virtual machine, I would have assumed the file had been a misnamed patch version. I have downloaded the file twice, there is no corruption.

CFP can be removed in Safe Mode, but do not attempt to install it under that environment. Some drivers required for installation may not load properly.

You probably have remnants of the partial-installation on your machine. If you’ve not tried these instructions yet, you probably should. It will take awhile, though.


Good luck.


That is the uninstallation guide I used. Unfortunately, it didn’t help. I even tried to break the installation on my virtual machine, I’m sure it’s not working properly, but it still launches fine.

Only recourse I can suggest is to roll back to a previously set System Restore point on the affected machine. I’ve done that several times, and it’s worked each time.

FWIW, I had to roll back to v3.0.14.273 after I was unable to reach the login screen on my IBM ThinkPad T43, which uses an embedded security chip to validate a fingerprint login. Tried everything…the previous version works fine now, though. I’m sticking with it until the next release.

As well, you might just consider sticking with v.273 if you can get your machine cleaned up from the botched installation.

I’m trying Comodo v3 out for the first time (tried v2 a long time ago). I haven’t had any versions installed on this Windows install. So, it’s new to my system. Which is why I don’t understand what the problem is. It has to have something to do with the installer itself. Do you know what engine it uses? The company name is plastered all over the properties.

I don’t know which brand of installation package the company uses. I couldn’t find the uninstaller executable. either, which might have revealed the name. Inno is a favorite among freeware distributors.

I’d pose that question elsewhere on the forum, as one of the developers or programmers might respond.

If you waded through my entire set of instructions for removing CFP, I expressed my discontent about this issue down at the bottom. I remember how bad it used to be trying to get rid of Norton/Symantec products.

Problem is, the more times you install and reinstall the same product – trying to get it right – the greater the risk that you become complacent performing yet another manual uninstallation and removing something really important that hoses your system.

I appreciate your input, USSS. Where should I ask the question about the uninstaller? This appears to be the best suited forum for the question.

Does anyone else have any ideas for me to try? I would really like to try out v3.