CPF 2.4 - Component Monitor - about to give up [FIXED]

There is something seriously wrong about the component monitor. It just won’t remember my rules!!! Sometimes it remembers which DLL files to block, sometimes not. I click “Apply” time after time. The very most annoying thing, however, is a DLL file related to Adobe Acrobat that I want to block. This has to be done EVERY time I start Microsoft Internet Explorer. CPF pops up a window, I click “Show Libaries” and block this DLL…

So now there are three choices:

  1. Switch from CPF to, e.g., ZoneAlarm. But I don’t want to do this.
  2. Uninstall Adobe Acrobat. Impossible, can’t work without it.
  3. Let Acrobat, and every little DLL file available, access the Internet. Impossible, I might just leave the door unlocked and open. It’s not that I don’t trust Adobe but I really want to block as many things as possible from the Internet, due to all the security threats.

Anyone else with this Component Monitor problem? By the way, when I switched from “Learn Mode” to “Turn On”, all Internet access was blocked. Why?

System: Win XP Home SP2, CPF 2.4.16.174…

/L

Hi LeoniAquila

I’m sorry you’re experiencing problems with CFP.

To address your last question first… no, I’ve not seen this reported before. I just tried it myself & it did work without any problems. I did try it several times.

On the Component Monitor not remembering, I assume that you are ticking remember on CFPs alerts (sorry, as you didn’t mention it I had to ask). Anyway, usually, CFP will also create a Log entry for alerts like this. Can you please post some examples of these duplicate entries? Preferably with the Component Monitor set to ON (it lists the individual DLLs, etc…). Thanks.

Concerning Acrobat, is the DLL in question actually listed in the Component Monitor?

Hi, with Adobe, “just a suggestion” if you block the dll, when you try to open a PDFon the internet, the main program still sees this and will ask for permission. The dll is probably blocked. Have you also tried the Application monitor to see if Adobe is listed? Blocked?

Also, the adobe dll being blocked I assume you mean PDFshell.dll ? However, Adobe may also be using OLE automation. Does it say this when it pops up something like Adobe has attempted to use IE through OLE automation or something on that order? If it does use this , blocking the dll won’t do any good since it changes a document and uses IE in order to access the internet and can change constantly. You may want to set your OLE alert level in this case so you don’t get these pop ups and I believe are automatically denied. No firewall can determine every OLE that occurs so either we adjust the alerts to lower setting or decide what we allow\don’t allow for each pop up.

I too use Adobe all the time but I allow it to connect for updates, online PDF documents, etc…In my “personal” opinion, Adobe Acro is safe enough to allow access. I haven’t seen any sneaky behavior as of yet with it and have used it for years.

I have read through some posts of yours, what other dll files are there? I noticed Adobe specifically but not clear on others. Even so , it may be as I stated, the OLE.

Hope this helps,

Paul

Thanks for your reply.

  1. Yes, I always check remember. But there are two separate problems: A) In the Component Monitor, some DLLs sometimes change from Block to Allow, after rebooting. Still I havn’t learned the pattern here, but MAYBE it happens just once, to some DLLs - and not at all to others. B) When starting up Internet Explorer, AcroIEHelper.dll wants access - sometimes immediately, sometimes after several minutes. This is where the “Show Libaries” appear, and I click “Block” and Apply here.

  2. As for the log, in the “Reporter” column only “Network Monitor” and “Application Monitor” are present. Thus, Acrobats attempts to access internet via AcroIEHelper.dll are not shown here. There are however some attempts from “Acrobat.exe” here, but program is easily blocked, and CPF remembers it.

  3. :slight_smile: It’s funny, after about three weeks of frustration with AcroIEHelper.dll, I may now have solved it!!! Via Internet Explorer’s (7.0) “Manage Add-ons”, I disabled this DLL, and two other Adobe DLLs (so now I can’t make PDF from HTML, but that doesn’t matter). Of course, Comodo must have asked every time I launched IE, because those DLLs were always loaded with IE?! Nevertheless, this doesn’t explain why Comodo never remembered the “Block” rule, but now it seems like the DLLs are totally disabled.

If the problem returns again, I’ll post a message later. Until that, thumbs up and thanks again for your interest!

/L

Paul, thanks for your reply.

I just wrote a message above, which gives some answers. Additionally:

pdfshell.dll is not in the list, and is has not asked for access either. I have seen it in its folder, but it doesn’t seem to bother.

Adobe Acrobat is currently a blocked application.

I rarely open PDFs on the Internet, so the problem doesn’t seem to relate to this.

“However, Adobe may also be using OLE automation. Does it say this when it pops up something like Adobe has attempted to use IE through OLE automation or something on that order?”

  • Can’t recall that I have seen anything about OLE, but maybe. Unsure.

“I have read through some posts of yours, what other dll files are there? I noticed Adobe specifically but not clear on others. Even so , it may be as I stated, the OLE.”

  • Last time there were several Adobe DLLs, maybe 10 or 15. Now they all seem to be properly blocked. A week ago or so, there were also some Autodesk (AutoCAD) DLLs that CPF didn’t really remember at first.

As written in my previous message, this particular Adobe problem may be solved now. Whether Adobe is sneaky or not, I’m sure you know more than me. The reason why I really wanted to block Acrobat now, was something I heard of a critical security problem with Acrobat 7.0.

Thanks a lot,
/L

Same here! That’s what started me on searching for a better alternative: Foxit Reader (much more smaller and secure). I think you are also correct that there are lots of dll’s being loaded when browsing, sometimes unrelated to the web page in question. For some reason when I switch Component Monitor from Learn to On mode, cmdagent.exe uses high cpu. With it back to Learn mode, it’s usually 0%, but that’s a different topic.

Hi glad it works. Just a note: I know of the security factor and assumed you were using the updated version . There is Adobe 8 which i am using.

Take care,

Paul

soyabeaner, thanks for the tip of Foxit Reader. I’ll check it out, but according to name - I suppose it only reads PDF files, not writes. I sometimes use editing (writing) functions, so we’ll se how it works.

Paul, I’ve also heard that Acrobat 8 is ok. I use 7.0 beacuse of my student license, but I think the latest update (7.0.9) takes care of that security problem.

Thank you guys!

/Lars

You are right, I checked it too. It is not free. But now when Acrobat don’t mess with me any more, I’ll continue with it. :slight_smile:

If you sometime want to write a pdf anyway, there are two excellent (free) alternatives: PrimoPDF prints from any program to a file, and OpenOffice.org converts documents to pdf.

Greetings
/Lars

Hi again, I use Adobe just for reading files and Nova PDF printer lite for making them as it’s free and when you choose print, you simply choose NPDF, print to file and you now have a pdf.

Paul

[attachment deleted by admin]