Could not remove file from Excluder List ?

I resolved the problem by uninstalling BoClean by using Revo Uninstaller and reinstalling BoClean,
but hope you might be able to suggest what I should have done to resolve this situation.

As I stated in Melih’s corner I have been with out the use of the left mouse button since last week.
Yesterday Tuesday morning, BoClean was updated and Avira started doing its update. CMF gave a memory warning that I could not respond to, etc.

The problem that revolved around BoClean is because of the new release and definitions the BoClean Warning about conflicts with the installed version of AVCenter in the BoClean Excluder and the new version.
Directions were to remove it from the Excluder list and you Browse to install the newest version.

I tried in regular mode it looked successful but when reopening the excluder list it was still there.
Tried doing it in safe mode and again AVCenter was still there when reopening the list.

As I mentioned in an earlier post, I moved all my security programs into BoClean Excluder to try and improve on cpu usage. Many anti malware programs get Kick started when another one is in action. Thought this might reduce unneeded startups by BoClean. But not sure if AVCenter was the right choice? Chose it because it was the Desktop icon created by Avira.

As I mentioned I finally uninstalled BoClean and reinstalled the latest version.

Just wonder if I did something wrong though because after uninstalling using Revo Uninstaller and running registry and temp files cleaners and rebooting, I got the warning are you sure no other versions of BoClean are installed?

The install continued successfully.

Thank you for any suggestions,


Oh I have never found any BoClean reports?

Let’s answer the “report” issue first - that’s by design. BOClean was originally designed to remain silent (and in most installs, completely invisible as it was intended for corporate desktops where the admins didn’t want the users to even know it was there usually) and same for the report mechanisms since they were originally designed to write to a common corporate-wide location for those same admins. So by design, the only time there will be a report is a) it’s “turned on” and b) something actually happened. Absent these two factors, there will not be a report. Perhaps in a later version, we can fill up the hard disk with all sorts of “Hello? BOClean started, farted or had a cracker” or some such. Heh. But the objective in the design was to only write out something if something actually happened.

Now as to your excluder issue, my guess is that something else is going on there. First thing you might want to consider is burying your rodent or finding out why its tail isn’t wagging. Given your other issues, sure does seem like something’s hosed there. :frowning:

But as to the excluder, here’s a “last ditch desperation workaround” that will at least getus out of the fray … go to the “search for files/folders” thingy and be sure that “show hidden, system files” and any other potential hiders of data are set in the search function so that you can find ANY instance of the stored data for the excluder before you start the hunt.

You want to look for ANY copies of a file called BOC426.DAT …

DELETE any and all copies you find, and once ALL copies have been deleted, then you can run the excluder without any further misadventures. But suggest since other things are wobbly, you just might want to look into what else is broken. Went and rechecked the code we released, and the excluder gladly rewrites its BOC426.DAT file correctly and no wobbles found. So it might be permissions problems perhaps on your end which disallowed the rewriting to that file, or something even weirder. If you find more than one copy of BOC426.DAT on the system, then this is almost assured, particularly if you have Vista on there …

Not sure if this the same subject, but I added 3 items to the excluder list - ‘drop and drag’ .I have now checked the “programme excluder” and it is empty?. Should the 3 programmes be there?
I am using the new version [ 4.26 ] and for example one of the programmes i dropped across was ‘spybot’

Sounds like these issues are the result of either “permissions” restrictions on what should be open for read/write to all programs and users, or some other “security” program is interfering with the disk writes necessary to save changes done within the excluder.

The filename that the excluder saves to is BOC426.DAT and for Vista will be in:

C:\ProgramData\BOC426 folder

In XP and earlier, this folder would be:

C:\Documents and Settings\All Users\Application Data\BOC426

Might want to check the appropriate folder to ensure that read and write permissions are granted there. When BOClean is installed, it checks and sets this during the install only, then reverts to whatever permissions existed prior. That’s about all I can think of since retesting of the code has determined that BOClean itself is OK.

So if it’s not permissions, then it might help to know what “security” programs are being run where this problem exists and hopefully, a few commonalities might appear.

I think i may have cracked this one. I went into excluder list from the configuration menu , once done i clicked ‘finish’ . I dont think this registered , however I have now done the same through the ‘excluder button’ and clicked ‘done’ this time and they seemed to have been saved … so “operator error” … sorry…

KEWL! I’ve always been a sucker for a happy outcome and nobody down. :slight_smile: