could not install CPF, telling me its already installed, pls help!

Hello Melih
I tried to post the below message but kept getting a box saying “Try Again” or report to an “Administrator”. Can you please help me!

Many thanks.

Downloaded CFP, but could not install. After pressing ‘run’ a small box appeared saying…“Comodo Firewall Pro is already installed on your system. Do you want to un-install it now?”, with 2 buttons…Yes or No. Tried both options, at my latest attempt I saved it to Desktop with the same results, as I’ve now downloaded several times and tried the ‘run’ option to no avail. CFP is not in “Add Remove Programs”, also did a search of my pc, and nothing to be found re CFP.

I have the AVG Free Edition anti-virus and anti-spyware. Can anyone please help this very simple soul?

Posted on behalf of heyyou.

same thing is happening to my computer.

so do anybody have any ideal to fix this.

First, check in the registry (start/run, type “regedit”) for the existence of this key:


If it’s there, remove it, reboot into SafeMode, and attempt to reinstall.