Corrupt "Network Control Rule" Window

when trying to add a new rule to an existing policy in comodo, i get 2 windows superimposed over each other. the result is unreadable, and so i am not able to edit.
try this:firewall → advanced → network security policy → select a program with custom policy–>edit–>add
for me, the resulting “network control rule” is unreadable
it seems the garbled part is at the top. the tabs in the bottom half seem ok.
can someone else duplicate this issue??

I have not had that problem, but maybe a related one. Was Comodo working OK previously? Are you using Vista or XP? Have you exported your settings? I had a problem with corrupt settings yesterday, and solved it by going to miscellaneous/“manage your settings” and doing an “import as” of previously exported settings and then a “select”.

i had this issue in v2 as well. other than this problem, comodo seems to work ok. i have defense+ deactivated. on occasion i do loose my network connection. i know this is a comodo issue too because it returns if i exit comodo.
i’m using a relatively new install of xp-sp2.
i tried your import suggestion. that didn’t seem to help.