Corrupt file from softonic

Hiya there

I am installing CISP on a new computer, I have been to the link provided at the main site at, but the file it downloads says it’s corrupted every time I tried to install it.

Here is what i did

  1. deleted the install file, rebooted and and re-downloaded and tried again… same result.

  2. did the above this time wiping the old install file with ‘eraser’ and clearing my browser cookies / downloads etc. then re-downloading and trying again.

I connected an old external hard drive which I knew had some downloads from earlier this year and installed CIS from that with no problems clearly the downloaded file was in some way corrupted. This may be a temporary thing or I may just have been unlucky but it might be worth looking into.

Also I was wondering is for future downloads if there is a direct download link anywhere, i always feel uneasy downloading from an external site (though I understand why it’s done that way) ?

Problem solved for now
Many thanks

Hi possibletarian,
Good to hear you have it sorted for now.
For future downloads, the direct links can be acquired from the Forum.
New and current releases will be posted in the section below.
News / Announcements / Feedback - CIS

COMODO Internet Security 7.0.317799.4142 Released!

Kind regards.

Thanks for that Cap’t

Yes all sorted, up and running… many thanks :slight_smile:

You are welcome. :-TU