cookie exceptions not working (unlike chromium) [Solved]

This bug relates to comodo dragon 28.1.0.0 / based on chromium 28.0.1500.95 on Windows 64 bit. As far as I can tell this has never worked correctly in previous versions of dragon.

Steps to reproduce. I’m assuming a fresh setup with no extensions and empty cookies/local storage/cache.

  1. Under settings/advanced/content settings, set Cookies => “keep local data until I quit my browser”
  2. Under “Manage exceptions”, set an exception for any site that uses cookies. I’ll use “[*.]metoffice.gov.uk” as my example and set it to “Allow”.
  3. Visit the site and set a cookie. On metoffice.gov.uk, this can be done for example by entering “Birmingham” in the “Enter place name …” box on the left and selecting the first option from the dropdown.
  4. Check the cookie has been set: open a new tab at metoffice.gov.uk. The left bar should show Birmingham rather than London weather forecasts.
  5. Close Comodo Dragon and re-open (If you are using the ‘keep running in background’ option, you may need to log out and in again to Windows to kill the process). Return to metoffice.gov.uk.

Expected behaviour: met office displays the Birmingham forecast (the cookie is retained). This is the behaviour on all non-comodo versions of chrome/chromium I’ve managed to test including 34.0.1845.0 on windows and 31.0.1650.63-0ubuntu0.12.04.1~20131204.1, however it’s been working like this for as long as I can remember.

Actual behaviour: the cookies are erased. metoffice.gov.uk displays “London” (the default). If you look at the cookies before opening the met office page, they’re gone!

EDIT: updated dragon to 31.1.0.0, problem still exists.
Mod edit: Added solved to the topic title, Captainsticks.

Hi and welcome koopa,
As far as I am aware the exceptions list is only to allow/block/clear on exit for the site data depending on your settings during the session, the ‘Keep local data only until I quit my browser’ is to remove all cookies when the session is finished regardless of the exceptions list (Intended behaviour).
Notice there is no ‘Save site data on exit’ in the exceptions list.

Kind regards.

Hi captain,

Which behaviour is “correct” I don’t know, but I’ve got both chrome and chromium on linux and chromium on windows, all of which will keep cookies listed as “allow” when closing the browser even when all other cookies get cleared. Dragon, for some reason, doesn’t.

I find the chromium behaviour more useful than the Dragon one myself as I can manually whitelist my favourite sites so I stay logged in between browser sessions whereas all other cookies get cleared.

Hi koopa,
I am standing up to be corrected and to apologise to you. :-[
I have just done some exception testing with Dragon and with ‘Keep local data only until I quit my browser’ enabled it is saving site data for those on the exceptions list.
This is the behaviour you expected as your other browsers are doing and not the behaviour I expected.

So now why does Dragon work as you expect it to for me and not for you?
Just out of curiosity have you tried the portable version or ever created a new user profile when installing new Dragon versions?

Edit: I have just tested your exact instructions listed in your opening post and the cookie/location remains as Birmingham upon relaunch for me.
There is something specific to your system or settings.
Under ‘Clear at Exit’ in the privacy section are the check-boxes empty?

Thanks.

No problem!

I’ve reinstalled dragon, deleted my old user profile directory and the problem’s disappeared, so I guess I had a corrupt cookie database in my old user profile. Dragon also starts up a lot faster now.

Thanks for the quick reply.

Thank you, it might just make me do some more research and checking in the future before jumping the gun. :slight_smile:
Good to hear that the issue is solved. :-TU

Thanks and kind regards.