Continuous loop of needing to restart computer to continue installation

I was having problems with CIS version 8 after upgrading to Windows 8.1. It said that the network firewall wasn’t configured properly or some error like that. The status showed at risk. I tried running diagnostics and it said that errors were found but it could not fix them. In Windows 8, I tried the diagnostics program but although it said it couldn’t fix the problem, it always worked every time after a restart. This didn’t work when I ran diagnostics for CIS in Windows 8.1 and restarted. After restart, it still said the network firewall wasn’t configured properly and gave a status of At Risk.

I figured I would uninstall CIS and re-install it. I was hoping this would solve the problem, but this has only created a new problem. Now, when I try to re-install CIS , I get an error message stating that the computer must be reset for installation to continue. I restart the computer and once again I see the same error message. I can continue this over and over again with no change whatsoever. How can I get CIS re-installed again? Currently I am using Windows Defender, but I would rather use CIS. Right now, I can’t even install it because it shows this error message even after restarting the computer.

I found this item in my startup in Task Manager called CisD7B3. Is this the cause of my problem? I thought perhaps it was from Comodo Internet Security because it started with CIS in the name, but perhaps it isn’t related to CIS at all. Anyways, any help would be greatly appreciated.

[attachment deleted by admin]

I have resolved the issue by deleting an old registry entry from the previous installation.