Containment not blocking access to files/folders

Hi, I’ve updated to the latest CIS firewall 12.2.2.7062.

I select the option “do not visualize access to the specified files/folders”
By default it blocks access to C:\ProgramData\Shared Space.

In windows explorer, create a file C:\ProgramData\Shared Space\test.txt

start my browser virutualized… In my browser open file C:\ProgramData\Shared Space\test.txt
Its not blocked. from my browser.

Is there something else I need to check or do to make this work?
Also tried this in the previous release of CIS firewall 12.2.2.7036 and it did the same.

Thanks for help and suggestions.

Why would you need to not visualize shared space, its already shared between the virtual space and the actual OS… ??? Are you trying to block it from the virtual space?

You should read the help docs as I don’t think you understand what that setting means and how the container/virtualization works with CIS. Containment Settings, Containment Computer Security, Desktop Software | Internet Security

Thank you for the clarification of how that feature works. Is there someway to sandbox files and folders in CIS so they are not readable in the virtual container?

Add files/folders to Protected data.