Constant Update Icon On TaskBar

I’m having a Comodo Firewall Update problem.
I get an icon on the taskbar for Comdo Firewall Update, click it and it opens a small box that says updates are ready to be installed. I click yes, am told that I need to reboot. After I reboot the same icon is back.
I just tried it again today, as I was going to remove cfpupdat.exe from the folder so it will stop running and wanted to be sure what I’m saying is accurate. Please let me know if removing cfpupdat.exe is a solution to this aggravation.
When I did it today, after reboot, the main Comodo Firewall icon did not show up, altho cfp.exe process was running. I clicked the main icon on the desktop and then the normal CFW icon showed up.
I’m running Windows 7 Home Premium SP1 64 bit. I am only running the Comodo Firewall Free version 5.5.195786.1383
For now I’ve removed the cfpupdat.exe from the folder it was in and am not being bothered atm. But if there IS an update, I’d like to get it, especially if it improves security and/or performance.

Any help will be appreciated,

5.8 is the latest version, if using ht auto updater it may require to update twice. I prefer to update manually.

Hi Skilz853,
Please try the instructions found here.
Hope this solves your problem.

Hey captainsticks, you are da Cap’. :-TU It worked like a charm ;D. The file in Repair was 95 kb smaller that the one that I moved from Comodo Internet Security to get the update icon to quit appearing in the taskbar.
I am suprised there were two files with same name different size in those two folders, but sure am glad the one was in Repair :smiley:
I have not rebooted yet, but I saw it download quite a few files, which is something I’ve never seen it do when it said updates were available. I’ve been up for 36+ hours atm and need to get some shuteye.
I’ll reboot when I get back up. I’ll post back here with an updat.

Thanks again for your help,

Hi Skilz853,
That looks promising, the original cfpupdat.exe appeared to get corrupted in some situations maybe during an update (Definite reason unknown).
Good luck and hope all is well after reboot.
Thanks goes to Forum Member Ache and Moderator Ronny for this solution.