Constant Issues with installing Comodo IS (or FW) 5.x on 64bit Windows 7 Machine

I am writing about an issue, that seems to be re-occurring. I have searched on these forums and on other sites for a solution, however still have not found anything that works yet. I have been using and upgrading your product on two of my laptops and I love it. I have used version 3 (from time to time); however since about version 4, I have been solely using (instead of trying other products) Comodo’s Firewall.

Old laptop = XP (32bit), with 768MB of Ram, and about 1.79GHz AMD processor
“new” Laptop = Win7 (64bit), with 4 GB of RAM, about 2.2GHz dual core if i am not mistaken

Avira is (updated DB and versions like Comodo) the Antivirus on both machines. Also both Laptops have two malware scanners (freeware versions) … Super Anti-spyware AND Malwarebytes

The issue has happened time and time again, from 4.0 to 5.0 and 5.2, 5.3, 5.4, 5.5 and now the 5.8 Upgrade. I HAVE TO SAY that Comodo was installed and working on both -laptops. The issue NEVER has happened on my XP Laptop, but only my 64bit system. About 90% into the installs, I get various errors… up to 5.5 it was an error (I can not recall the exact message) related to cavshell.dll

ANYWAY, now (Version 5.8) I am receiving an error, “Cannot install COMODO Firewall… Error 1603. Fatal error during installation” … with the old (what i wrote above) error message in the event log. I have tried every suggestion “Mods” seems to have suggested, from installers like Revo, MANUALLY searching regedit and folders for Comodo related items … even the numerous “Uninstaller” bat files. The only way I can get Comodo Internet Security on my 64bit PC anymore is to reboot (via hitting the power button BEFORE the 1603 error at 99% done (otherwise the installer removes EVERYTHING it installed) I am truly baffled at this point … I do not WISH TO GO to another product (vendors). The issue with the 99% reboot method that worked on pre-5.8 versions is that now anything I try to install anything that involves MSI … it says “Comodo install suspended …” and then removes Comodo, so in a sense I am removing and reinstalling Comodo EVERY TIME I install something. I have also tried the “Windows installer Cleanup” app that I already had, but it doesn’t list ANY Comodo related items. (I am trying to list everything here so the techs have a complete picture)… I have also tried some debugview method of monitoring what is going on; however, ran into trouble… I HAVE tried “run as Admin” (as I am the admin and these are my personal Machines) for the installer.

Like I said I never have this issue on my old laptop and am getting frustrated as its a never fixed issue. I am not BLAMING Comodo and is could be a registry key (have run a few trusted cleaners I have in the registry + manually searching) or some goofup Microsoft made … if its something like a (non-Comodo=related, dll in system32 that I am missing, and putting it back in it’s place fixes the install issue, I will gladly post back here, for others who have the same problem.

Again, it seems like since I think it was 4.x, the issue always seems to be with cavshell.dll … AND SOMETHING I just remembered to post… I am NOT TRYING to install the firewall at all … .even if it have the CIS installer (instead of CFW installer) I always uncheck Geekbuddy and CAV. (just for the tech’s FYI)

Thank you all for your time,

Ok I have not confirmed this works, but I wanted to update what is going on

I have done an install as described above via the reboot at 99% BEFORE any messages are displayed … Comodo seems to be working (I always backup my “Config” every so often anyway, so its a matter of just re-importing … .no big deal)… The Message I kept getting when trying to install other software (that uses “Windows Installer”) was that Comodo’s Installation is suspended (checking the Comodo folder at this point and it only contains a few .TMP files, as it has already been uninstalled by the time that message is displayed.

I know this is for a different program; however, I found which points to removing the key at “HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress” … I have not tried to reinstall anything (/install … whatever) since the latest Comodo install, so I do not know if it works for sure; however, if it doesn’t I am not sure what to try next… I am just hoping A) This works B) Maybe if it doesn’t work for me, doing the install this way, and deleting that key to prevent Comodo from removing itself (Windows installer really, not Comodo) can help someone else with this same issue… I will post back either way, to show if this has fixed my issue (one of them anyway).