Connection to Appache HTTP server results in "time out" error

I run Apache HTTP server and have registered a public DNS on
Now my friend and I tried to set up a test, so my friend could get access to my server and download a file that I shared. We attempted to set up a connection when Comodo firewall was switched on and when I disabled it, however both attempts resulted in my friend getting a “time out” error screen.
Any thoughts how we can resolve the problem?

First question is how did you disable the firewall? Notice that closing the client, cfp.exe, does not disable it.

When testing to see whether the firewall is in the way it is easiest to right click on the tray icon and set Firewall Security Level to disabled.

When you want to see if D+ is in the way you need to go to Defense + → Advanced → Defense + Behaviour Settings → enable “Deactivate Defense+ permanently (Requires a system restart)” and reboot when asked.

Of course don’t forget to enable afterwards as CIS won’t remind you.

Are you using the default Internet Security Configuration?

CIS is maybe not the culprit, it is not that easy to run a http server, particularly if the public ip is dynamic.

The trouble could come from the lack or from wrong NAT rules on the router if any.

Assuming the http server is set by default on port 80, both port 80 and 8245 (default for No IP) must be natted to the lan ip of the “server computer” (and of course, No IP Duc must be running), independently of the firewall itself, and even if it is of course better to make the first tests when the firewall is closed.
Make virtual server or dmz rules to the “server computer”, dmz usually works better.

It might be easier to first test the “No IP connectivity” using some remote connexion software, ultravnc is a good client for that (but still assumes that ports 80 and 5900 are correctly natted).
Teamviewer would still be easier as it requires no specific ports.

Last, if only wanting to share and download files, it is far easier to set not a http server, but a ftp server.
In this last event, and since you cannot test yourself your server if you don’t have another non-LAN computer with another ip, you can test the connectivity online:

In order to disable it, I did 2 things
System tray → Comodo Firewall → Firewall Security Level → Disabled
System tray → Comodo Firewall → Defense+ Security Level → Disabled

Yes, I am actually