Connection from notebook blocked - need help

I have a desktop connected through an ethernet to a wireless router and need to share files on the desktop and any notebook connected via wireless. I can connect to a notebook shared folders from the desktop but can’t get the notebook to connect to the shared folders on the desktop.

I’ve created a LAN network zone with the ip address of the notebook as well as the ip address of the router under LAN. I’ve also set up a Global network security policy with the source as the LAN and all ports/address for destination.

I need to primarily use Beyond Compare to sync the folders but occassionaly “direct” connect to the folders.

I’ve been able to see the folders on the desktop from the notebook via Network Places but can’t access any files (a permissions error pops up, but without Comodo I can access fine). Beyond Compare doesn’t even find the folders.

All to no avail. I need help to make this work.

Running WinXP Pro (one desktop, two notebooks, and occassionally 1 notebook Vista).

I did search but couldn’t find a topic that answered my question. If there is one posting a link would be much appreciated.

Thanks in advance


You should only need a single zone that encompasses all IPs on the subnet used for your LAN ( to for example. Once this zone is established, you will need to create rules (one for inbound and one for outbound) on each PC that is running CFP. You can get away with a single rule with a direction of IN/OUT, but my preference is to create separate IN and OUT rules to make it easier to troubleshoot.

Does the laptop get its IP address through DHCP from the router? If so, try setting a static address on the laptop, rebooting and testing the connection. There have been hiccups with DHCP renewals.

Let us know how this goes.

Ewen :slight_smile:

Thanks Ewen, but I’m still not able to connect properly.

I can connect the laptop and see the folders on the desktop but when I double click on the folder I get a Windows error that I don’t have permission to access that folder.

I thought I could disable the firewall via Disable but it still seems to block access to the desktop.

I’ve uninstalled and can access the folders without a problem and I can use my previous firewall with a packet filter enabled and can access it. I want to return to Comodo though.

The router does have DHCP but each notebook seems to always have the same ip address.

I’ve set up the Global filers for inbound using various configurations - zone, ip address, range, and all with no success.

Obviously I’m totally lost. Any further help is greatly appreciated.


When access is denied, are there any relevant entries i the logs?

This should tell us why it was denied, which is the first step towards gettings it allowed.

Ewen :slight_smile:

All the logs seem to show Allowed.

In order to read files within a folder does any additional rules need to be set up?


Two things to try for starters.

  1. Assign a static IP address to each PC on your LAN.
  2. You’re currently using netmasks in your zone rules. Try changing them to a range of IPs and make sure the range covers the entire subnet you’ve used in step 1 (including the IP address of your router).

Ther should be no difference between using a range of IPs and using a netmask to establish the zone, but I generally prefer to work with absolute values, hence the no DHCP and definitively nominated IP ranges.

Make sure the zone LAN rules are above any block rule you may have.

Let us know how these go.

Ewen :slight_smile: