Connecting wirelessly, I must disable C-Firewall then re-enable it!

Hi folks,

I’ve just learned that Windows Firewall is in fact not the best firewall out there lol. And after doing some Googling, I’ve found that Comodo seems to be the best one. However, every time I turn on my computer (WinXP MCE), my wireless Internet connection has ‘limited connectivity’. To make my connection work properly again, I must disable the Comodo Firewall, then ‘repair’ my wireless connection and now I’m back connected to the Internet. I enable the Comodo Firewall again with no problems, until I turn off my computer and turn it on again to repeat the process.

I made my wireless network trusted in ‘Stealth Ports Wizard’ thingee. I can’t understand why it keeps doing it. Any help would be so greatly appreciated. TIA

I manage to solve it myself, by simply uninstalling Comodo then reinstalling it again. So all working properly now!