connected laptop to a new network, can connect only to some sites

I connected my laptop with the newest version of Comodo Firewall to a new network, in a different office and I cannot connect to some sites, while some are working fine. Also it seems https connections do not seem to work, even though when i run tcpview.exe it shows established https connections with the servers, but the pages don’t display.

When I switch Firewall Security Level to “disabled” everything works fine.

Any ideas? I’m thinking I should change some settings in terms of connections with etc…

For example I can connect to just fine, but when i type in I can see the address bar in my browser change to but the page doesn’t actually open. Tried it both in Opera and IE.

My system is spyware free, my hosts file has not been hijacked etc…

Everytime I reboot the pc Comodo detects the network again…

Any ideas at all?

Can you post some more details such as the IP address range of the newly detected networks. Perhaps an image of your firewall log file at the time you were unable to connect. You might also run an ipconfig /all from a command prompt and post the results.

I don’t see much being logged by Comodo. For example I started IE and tried to connect to and couldn’t but nothing showed up in the logs.

So i fired up Opera and got this logged:

Date Application Action Direction Protocol Source IP Source Port Destination IP Destination Port
2011-10-25 00:36:35 C:\Program Files (x86)\Opera\opera.exe Blocked Out UDP 57896 1900

I’m connecting to the Internet through a router. I log in to it at

The problem seems to be the communication between Comodo and the router. I can get on the INternet just fine with Comodo switched off and when I get online at a different office with a different router I can leave Comodo on and it’s working fine

The log entry you’ve posted is a UPnP request, which shouldn’t affect your ability to connect to web sites via the browser.

Can you specify the IP address ranges used when new networks are detected, and post an ipconfig /all when you can connect and when you can’t.

thanks Radaghast. it seems to be working now. i navigated through the maze of comodo “settings” and “activated” the firewall somewhere? even though my firewall security level was set to “custom policy” all the time (wasn’t disabled)… some other stuff stopped working now but that’s a subject for another thread