configuring firewall to allow xbox 360 to connect with v3.9

Under your faq, configuring the firewall to allow streaming to xbox 360 has instructions that seem very out of date,

https://forums.comodo.com/frequently_asked_questions_faq_for_comodo_firewall/xbox_360_live_tutorial-t4408.45.html

since it references menu options that don’t exist in the current version of the Comodo firewall (3.9).

I am currently running Windows XP, so I do not need the settings for Vista’s Media Center, but I do need step by step instructions that show me how to configure the firewall settings.

Right now your faq still has instructions from 2006:
“First define your trusted zone. For doing this go at “Security”->Define a New Trusted Network”

Then create a network rule. Go at “Network Monitor”, select “Add rule” and create the following rules:"

But the closest thing to “Security/Define a New Trusted Network” seems to be “Define a New Trusted Application” and “My network zones”

thank you for your help.

Hi GWJRoo, welcome to the forum.

having looked at the FAQ, I agree it could do with updating. Unfortunately, I don’t have an xbox, however, I am more than happy to try and help you get this working.

Looking at the original FAQ, it seems to suggest that the first thing to do is create a new ‘Trusted Network’ which translates under CIS to ‘My Neywork Zones’.

Essentially, a ‘zone’ is a set of IP addresses that you can define and then use when you create rules. For example. Your home network maybe using 192.168.0.0 - 192.168.0.255. In which case you can create a zone in which you define these addresses and give it a name, maybe ‘Home’. Later when you come to create rules, your can use the ‘zone’ name as part of the rule.

The idea here is that all devices on your home network ‘zone’ will use an address within the same range. Because you ‘trust’ devices on your home network you can create rules the allow communication more easily. For example:

In Application rules you could have two rules that look something like this:

Allow IP OUT
Source Address = ANY
Destination Address = ZONE
Source Port = ANY
Destination Port = ANY

Allow IP IN
Source Address = ZONE
Destination Address = ANY
Source Port = ANY
Destination Address = ANY

This allows two way communication between your PC and any device on your network that shares the same address range.

In addition to Application rules you will need to allow the xbox a way in through Global rules. According to the FAQ you have to allow:

UDP IN to ports 1900,3776,7777

and

TCP IN to ports 3390,3932,5555

So once again, using the predefined ‘ZONE’ create two rules. However, before you create the rules, to make life easier, do this:

Firewall - Common tasks - My Port Sets

Create a new port set, call it something like ‘xbox UDP ports’, then add ports 1900,3776,7777. Do the same again for TCP and add ports 3390,3932,5555.

Allow UDP IN
Source Address = ZONE
Destination Address = ANY
Source Port = ANY
Destination port = xbox UDP ports

Allow TCP IN
Source Address = ZONE
Destination Address = ANY
Source Port = ANY
Destination port = xbox TCP ports

That’s as far as I can go right now. Have a play around and see how it goes, we can revisit the problem once we know what’s what.

I read through your instructions, and while they are clear, they somewhat assume my IP address isn’t wildly dynamic. I have no idea how my ISP is assigning me an IP…but even the first digit is different most of the time.

I was fiddling around with the other firewall options and I found a work-around that you may want to add to your faq:

If you’re running Windows XP, and in your Xbox360 you try to connect to your PC through the “Video Library” option, there is a process that appears “wmpnscfg.exe” because the xbox is trying to use Windows Media Player as the go-between for streaming the videos.

I used the Comodo Firewall “Define a New Trusted Application” and then Select/Running processes. Found the process (near the bottom) “wmpnscfg.exe” and allowed this application, and voila…streaming video from the PC to the Xbox 360 without defining complicated rules.

thanks for the time you put into your response, and I hope this work-around will help someone in the same situation.