Configuration to allow incoming VNC connections

Hi There,

First of all, thank you guys for this nice, powerful and non-leaking free firewall !

Now, my question is (I could not find the answer to it despite my searches in that forum and google) :

How to setup Comodo Firewall to allow incoming TCP connections for a VNC server (UltraVNC).

I am using :

  • the latest Comodo Personal Firewall version
  • My internet connection is a Direct connection with ADSL (always connected)
  • Windows XP latest with update
  • UltraVNC server latest version

My problem is that I can’t get to connect to My home rig using UltraVNC.
It used to work previously with my old firewall (I won’t name it, no need to flame that thread), where I allowed the firewall to allow incomming connection to UltraVNC on the given port (the port on which UltraVNC is listening).

I always get a connection refused with CPF…

When I start the VNC server on my home rig, I click on allow to act as server and remember the setting.

Here is the application setup in CPF :

Here are the rules I have in CPF :

Everything is as set by default…

There seem to be no problems with utorrent for which I did the same and that on which I receive data for distant peers…

I tried several things such as rules allowing the port… without success… So I came back as it is by default.

Any thoughts?

Thanks in advance for any help/hints.

By the way, maybe a little bit off-topic, but now that I look at it, utorrent does works & does download/seed, but I see the yellow and it says no incoming connections…

I know the answer and how to change that and make the icon go green :

But how is it possible to actually download & seed … if CPF blocks it ?

I tried again, without sucess…

I did set up two rules before the rule 0 that :
0. allow TCP IN from to <my_VNC_port>

  1. allow TCP IN from to <my_computer_IP> <my_utorrent_fixed_port>

Now utorrent looks ok and the icon is green. But VNC still does not work

Do I really have to set up something in application setup ?

I finally got VNC to work, thanks to the rule #0 above. What was wrong was the I messed it up with a fingercheck…

Thank you for your help.