Config works only once

Hi all,

I have a problem with the Comodo Firewall v5.3 and hope that you have an idea how to fix it. I have / want to use the software DAS (Device Access Server) from Infineon Technologies AG which allows the connection to their TriCore microcontroller devices via USB. Therefore it opens a so called DAS server (TCP/IP based) that opens a port e.g. 1777 (but this varies and is not always the same port) and listens for connections on that.

First of all after I realized that this server does not work anymore after installing the firewall I tried to completely disable the Firewall and Defense+ but this does NOT help :/.

Then I used a VMWare and tried various things with the following result: Complete clean Windows → everything works fine. After installing Comodo the DAS server stops to work. Then I put the Firewall and Defense+ on training mode and opened the DAS server again. All rules were created accordingly and it worked UNTIL I did a reboot :confused:

Now the connection again does not work anymore although all automatically created rules are still present and the Firewall is still in training mode. Even when I set all the exe files related to the DAS software to “trusted application” and “installer or updater” / “system-application” in Defense+ it does not work :/.

Do you guys have any idea what else I can try? I really need this Tool running and to be honest although I am using the Comodo firewall for a few years now this really makes me think about changing to a different one if I can’t solve this as it is really important for me to use this kind software.

Many thanks and kind Regards

Edit by EricJH: made a paragraph structure for easier access

I think the problem is that the device is on the USB port here. It is treated as a “mounted device” (think USB hd’s, USB flash drives, NAS and encrypted drives/partitions) and they are not trusted by default because they cannot be continuously monitored.

After a reboot CIS won’t follow the rules made before the reboot.

The only solution I see is to delete the firewall and D+ rules before you start the program after a reboot.

Next step could be to make a policy for DAS specific that you can apply when you get an alert or add in Application Rules.

Thanks EricJH for your answer. Unfortunately even deleting the rules after every reboot does not work. To be honest I don’t understand this. As I already said even disabling the firewall and defense plus does not help. Thats really strange.